Introdução ao Cifracil

Uma visão rápida do Cifracil

Seja bem vindo ao maravilhoso mundo da música através do Cifracil ! Este software tem como objetivo auxiliar as pessoas que trabalham com musicas cifradas. De que forma o Cifracil poderá auxilia estas pessoas ? Este software oferece um editor de textos inteligente, capaz de interpretar qualquer música cifrada que for colocada nele (seja feito através do editor do Cifracil ou um texto vindo de outro editor qualquer, como o Word, por exemplo). O Editor identifica cada acorde colocado no texto e busca em seu dicionário de acordes uma digitação default para o acorde identificado, desenhando-o em uma aba ao lado do editor. Quando o documento fica pronto, a música cifrada, o software oferece um preeview do documento, juntando o texto cifrado com o desenho dos acordes definidos no seu documento, tal qual páginas de um songbook.Aliás, o Cifracil permite você criar songbook com suas músicas prediletas ! Após salvar suas músicas no formato do Cifracil poderá criar songbooks com capas, indice, rodapes e cabeçalhos inteiramente configuraveis. O Cifracil também auxilia você a conhecer os acordes feitos no violão ou guitarra, apresentando um poderoso dicionário de acordes. O dicionário de acordes permite você pesquisar um acorde desejado, tanto pelo nome do acorde quanto pela digitação do acorde. Você poderá ver todas as digitações existentes para um mesmo acorde. O dicionário procura ser educativo. Você poderá desenhar um acorde com cliques do mouse e pedir para o dicionário identifica-lo. O dicionário te mostra os possíveis nomes definidos para o acorde desenhado, bem como cada nota e em quais modos gregos os mesmos poderão ser encontrados. E mais, nosso dicionário de acordes pode ser aumentado pelo usuário. Coloque novas digitações ainda não cadastradas no dicionário.

Agora que você deve estar curioso para utilizar o Cifracil clique nos links abaixo para saber como:

. Criar ou Editar um Documento

. Utilizar o Dicionário de Acordes

. Regras para reconhecer acordes no texto

. Regras para Utilizar Subscrito e Sobrescrito veja no item acima.

. Trabalhar com Afinações diferentes do Cavaquinho

. Importando uma Música para o Cifracil

. Criar ou Editar Songbooks

. Configurando Aparencia do Braço do Cavaquinho

. Configurando a Pagina de Impressão

. Configuração do MIDI

. Corrigir problemas com as tabelas do dicionário de acordes

. Fazer Atualização do Dicionario .

. Pesquisar Arquivos no Cifracil


Criar ou Editar um Documento

Para você criar um novo documento no Cifracil você poderá ir no menu clique com o mouse no ítem Documento e em seguida clique na opção novo.

Você também poderá utilizar a barra de ferramentas e clicar no primeiro botão.

O Editor do Cifracil será aberto. A Afinação do documento será sempre a afinação corrente, ou seja, a afinação do dicionário aberto no momento. Quando o Cifracil é aberto o dicionário corrente é sempre o da afinação Standard D G B D, a não ser que você tenha aberto um documento de outra afinação, aí o Cifracil coloca como corrente a afinação do documento aberto. Para mais detalhes sobre afinações e dicionário de acordes veja o tópico Trabalhar com Afinações diferentes do Instrumento . Na primeira linha você verá escrito Título da Música. Aí você deverá substituir esta frase pelo título da música que você irá digitar. Lembre-se que para o Cifrácil a primeira linha será sempre interpretada como Título da Musica no seu documento. Já a segunda linha do texto, onde está escrito Autores, deverá ser substituida pelos autores da música que você irá começar a digitar. Da terceira linha para baixo digite a letra e cifra da música que está sendo criada no Cifracil. Procure não misturar as linhas onde estão sendo escritos os acordes, com símbolos que não representam acordes. O Cifracil terá que interpretar o texto e tentará definir para cada linha, se ela é uma linha de texto puro ou se é uma linha de acordes. Se você precisar fazer um comentário em uma linha que contenha acordes utilize colchetes. Exemplo: [Intruducao] C F C F. O Cifracil permite também, no momento da interpretação de acordes, um recurso muito interessante e útil. Com o uso do símbolo asterisco *, colocado após o último caracter do acorde, você poderá colocar o mesmo acorde com digitações diferentes no mesmo documento. Ex: Imagine que você queira utilizar na mesma música, em trechos diferentes, a digitação do acorde de Mi Maior ora sem pestana, na primeira casa, e ora com pestana na quarta casa. Basta que você vá acrescentando asteriscos no final do acorde para que o editor de textos identifique cada Mi Maior como se fosse um acorde diferente. Poderia ser assim:

A E A E*

La la la ia

O Primeiro E poderia ser o Mi sem pestana e o E* poderia ser o da nona casa. Se ainda houvesse um outro Mi com outra digitação bastaria colocar E**. Para cada Mi maior você poderia definir a digitação escolhida clicando no botão com o título Mudar Digitação Acorde Selecionado localizado na aba Repositório de Acordes do .Editor do Cifracil

Preste atenção na hora de colocar os nomes nos acordes, pois o Cifracil tem regras para interpretar os acordes . Quando você terminar de digitar o texto mande interpretar o texto para que o Cifracil encontre os acordes contidos nele. Após o Cifrácil identificar todos os acordes do seu texto, é recomendavel que você verifique na aba Repositório de Acordes todas as digitações dos acordes apresentados. Se achar necessário, modifique as digitações que você quiser e finalmente salve o documento. Para ver com detalhes como realizar cada tarefa destas clique no tópico Editor do Cifrácil .

Para ver ou modificar um documento já salvo você poderá abri-lo de três formas:

1) Vá ao menu e clique com o mouse no ítem Documento e em seguida clique na opção abrir.

ou

2) Clique no segundo botão da Barra de Ferramentas

3) No Windows explorer, dê um duplo clique no documento Cifracil que deseja abrir e o Cifracil será carregado com o documento que você clicou. Observação: Não tente abrir o Cifracil mas de uma vez na memória de seu micro, pois ele não consegue executar mais de uma simultaneamente. Você só poderá fazer isto se instalar o cifracil na mesma maquina em diretorios diferentes.

Um dialogo será mostrado para você abrir o documento no formato do Cifracil. Escolha-o, clicando com o mouse em cima dele e clique no botão Abrir. A partir daí, altere, se necessário o documento aberto. Qualquer modificação efetuada no documento fará com que o botão de salvar apareça no Editor . Não esqueça de salvar as alterações realizadas em seu documento. Se você modificou algo de forma errada, basta fechar o documento sem salva-lo.

Lembre-se que agora voce pode abrir documentos em dois formatos: Cifracil Cavaquinho (.cfc) Cifracil Violão (.cfr) Cifracil Viola (.cfv) ou Cifracil Teclado (*.cft). Voce poderá filtrar na caixa de dialogo de abertura do arquivo o tipo de arquivo a ser visualizado para ser aberto (Cifracil Cavaquinho, Violão , Viola ou Teclado ).

.


Dicionário de Acordes

O Cifracil tem um dicionário completo de acordes. Todas as categorias de acordes serão encontradas neste dicionário. Porém, como um acorde pode ter muitas combinações possíveis de digitações, seria muito complicado disponibilizarmos todas as digitações que o instrumento comporta, então colocamos as digitações mais comuns para cada acorde. Mesmo assim, oferecemos uma boa quantidade de digitações para cada acorde.

O Cifracil, nesta versão, oferece apenas o dicionário de acordes apenas baseado na afinação padrão. (E A D G B E). do Violão e da Guitarra. Os dicionários de outras afinações poderão ser gerados pelo Cifracil. Veja mais explicações sobre dicionários e afinações no tópico Trabalhando com Afinações.

Poderemos acessar o dicionário de acordes em qualquer momento, mesmo com o editor aberto. Para chamar o dicionário de acordes, bastá clicarmos no botão com o desenho do violão, localizado na barra de ferramentas. Ao entrar no dicionário é mostrado qual dicionário está aberto no momento.(Dicionário da Afinação Corrente) Afinal, como já falamos antes, o Cifracil possui dicionários para afinações diferentes, mas somente um dicionário permanece ativo, aberto, por vez.Se desejar trabalhar com um dicionário de outra afinação basta clicar no botão da Barra de Ferramentas do Cifracil

O que fazemos com frequência em um dicionário é pesquisar. Aqui não será diferente. Podemos procurar acordes e suas respectivas digitações. Oferecemos dois tipos de pesquisa. Podemos procurar um acorde através do seu nome ou então de sua digitação (desenho). Para definirmos o nosso método de busca basta clicarmos com o mouse em uma das opções mostradas na caixa Pesquisar por., como vemos na figura abaixo:

(figura 2)

Para acharmos um acorde através de seu nome basta digitarmos o nome do acorde que estamos querendo encontrar na na caixinha abaixo e clicarmos no binóculo ao lado.

(figura 3)

Se o acorde for encontrado, será imediatamente posicionado na grade abaixo (figura 4), onde mostra o acorde corrente do dicionário e também podemos ver sua digitação desenhada ao lado direito da mesma grade.

(figura 4)

Cada Linha da grade apresenta uma digitação de um acorde. Como um mesmo acorde pode conter varias digitações, vemos varias linhas repetidas na grade, porém, se pularmos de linha em linha perceberemos que cada uma apresenta uma digitação diferente. Em cada linha temos quatro informações:

Acorde: Nome do acorde mostrado na linha

Afinação: Mostra a afinação correspondente do acorde daquela linha

Digitação Default: Quando está marcado com um X quer dizer que o acorde que está nesta linha será o acorde mostrado na aba Repositorio de Acordes do Editor de Textos, quando um documento do cifracil estiver sendo interpretado.

Digitação: A digitação representa a forma com que estamos dispondo os acordes no cavaquinho. Podemos por exemplo fazermos o acorde de Do maior colocando os dedos na 4.a corda - casa 2, 2.a corda - casa 1 e 1.a corda - casa 2, deixando a corda 3 solta. Temos de cima pra baixo Mi, Sol, Do, Mil, ou usarmos outra digitação , fazendo uma pestana na quinta casa pegando todas as cordas. De cima pra baixo teremos as notas:Sol,Do,Mi,Sol. Ambos os acordes representam o do maior, mas com formas diferentes de montar o acorde no instrumento, ou seja, com digitações diferentes do acorde.

Clicando nas mãos (apontando para direita e esquerda) poderemos navegar nos acordes do dicionário. Cada digitação do acorde vai sendo mostrada no desenho localizado ao lado direito da grade. Na exemplo acima, poderemos ver todas as digitações do acorde C, clicando no botão que tem a mão para o lado direito. A cada clique, novo digtação vai sendo mostrada. Se desejar caminhar no sentido inverso experimente clicar no botão que traz a mão apontando para o lado esquerdo. O próximo botão (Com a letra A), permite você modificar o nome do acorde. Tenha muita prudência ao utilizar este botão. O Cifracil já dá nome aos acordes, raramente você precisará modificar o nome de um acorde. Lembre-se que o nome que você der ao acorde será interpretado pelo Cifracil, por isto você deverá conhecer muito bem as Regras para reconhecer acordes no texto para que o nome que você der ao acorde seja corretamente interpretado pelo Cifracil. Recomendamos utilizar este recurso apenas se você precisou dar nome a um acorde, não encontrado pelo Cifracil, porque este acorde não foi encontrado em nenhum campo harmônico tradicional, no momento de cadastramento do acorde no dicionário. Então, se você tiver dado um nome incorreto para o Cifracil e deseja troca-lo, este seria o botão indicado para fazer esta correção necessária.Vemos ainda em cima da grade mais dois botões:

O botão tendo o desenho da borracha serve para apagar uma digitação do dicionário de acordes. O Cifracil não permitirá você apagar as digitações que já vieram previamente cadastradas para você. Mas todas as digitações inseridas por você no dicionário de acordes poderão ser apagadas.

O outro botão, contendo um sinal de checagem em vermelho serve para marcar ou desmarcar com o X a digitação default do acorde cadastrado no Cifrácil. Todo acorde deve ter uma digitação default, para que o editor de textos, quando estiver interpretando a música, achando os acordes do texto, busque no dicionário a digitação default para cada acorde encontrado. São eles que serão desenhados quando a música for interpretada.

Ainda falando sobre a figura logo acima, vemos dois números separados por uma barra: 1/3669. O Primeiro indica o numero do item da grade. E o segundo indica quantas digitações já foram cadastradas no seu dicionário. Ou seja, você está localizado no ítem 1 da grade que contém ao todo 3669 digitações cadastradas.

Poderá ouvir o som do acorde atual clicando no botão com um sinal sonoro.

Como já afirmamos acima, temos duas formas de pesquisar Acordes e suas respectivas digitações. Para pesquisarmos nosso dicionário em busca de uma digitação qualquer, precisaremos marcar a caixinha com o título Pesquisar por com a opção Digitação e em seguida, iremos desenhar a digitação que queremos pesquisar utilizando cliques do mouse para marcar e desmarcar as notas no braço do instrumento, como mostra a figura abaixo:

( figura 5)

A bolinha preta mostrada acima, na 2.a casa, 4.a corda, apareceu após clicar o mouse neste local. Para desmarcar a nota, basta clicar no mesmo local. Quando você quiser marcar uma nota originária de uma corda solta, então você clicará na direção da corda que você escolheu, após a última caxa, em cima do X. Ao clicar aí o X ficará com aparência de uma bolinha (siginificando corda solta). O X significa que aquela corda não está sendo utilizada na montagem do acorde que você está desenhando. Para mais detalhes sobre a representação grafica do acorde no Cifracil clique aqui. Pois bem, agora que você já sabe desenhar o acorde, para procura-lo no dicionário, basta clicar no botão que contém um binóculo, localizado na figura 5, para que o acorde desenhado seja localizado. É importante lembrar que este botão só estará ativo se você tiver marcado a opção Digitação da caixinha Pesquisar por.

Aproveitando ainda a figura 5 vejamos para que servem os outros botões que aí estão:

O primeiro, o que tem uma borracha, serve para limpar o desenho do acorde, deixando o desenho do braço do violão limpo para que você comece um novo desenho de um acorde.

O Segundo botão, acabamos de explicar acima, serve para procurar no dicionário uma digitação qualquer que desenhamos.

O Terceiro botão, contendo uma lupa, será de muita importancia para nós. Desenhe um acorde qualquer e clicando neste botão, o Cifracil analisa o desenho feito do acorde e mostra pra você quais os nomes que este acorde pode receber. Para aquelas pessoas que fazem o acorde no teclado e não sabem dar o seu nome correto será muito bom utilizar este botão. Este botão também será obrigatoriamente utilizado quando queremos cadastrar uma digitação nova no dicionário de acordes do Cifracil. Desenhamos o acorde, como já explicado acima e clicamos neste botão. Uma nova janela será mostrada para nós, como podemos ver na figura 6, logo abaixo:

(figura 6)

Vemos uma estrutura ramificada, como se fosse uma árvore, semelhante a estrutura de diretórios do Windows Explorer. Neste exemplo acima (figura 6) o Cifracil achou 4 nomes possíveis para um acorde que você desenhou ( como já mostramos na figura 5). Se você

ainda quiser saber para cada nome encontrado, detalhes da estrutura de cada acorde apresentado para você, basta clicar no desenho do + e você então verá:

As notas do acorde na primeira linha mostrada;

Os intervalos correspondentes a cada nota, na linha logo abaixo;

E finalmente clicando no + da palavra Modos, serão mostrados os Modos gregos onde este acorde pode ser encontrado. Se você estiver cadastrando um novo acorde, quando esta tela foi chamada, você então deverá clicar sobre o nome do Acorde escolhido por você. Neste momento o nome do acorde clicado estará dentro da caixa intitulada Nome do Acorde. Clique no primeiro botão ao lado direito desta caixa e você tera copiado este nome para o desenho do acorde que você fez. Você verá isto acontecer logo após ter clicado o botão mencionado, pois o Cifracil fecha esta tela e você volta para a tela do dicionario de acordes. Se você deseja salvar esta digitação do acorde encontrado, basta clicar agora no botão contendo um disquete (veja figura 5).

Falando ainda sobre a janela anterior, a que mostra os acordes identificados, faltamos falar sobre dois botões localizados na parte de cima da tela (figura 6). Temos uma lupa contendo um + e outra contendo um sinal de - . O primeiro servirá para abrir a arvore que contém os acordes, mostrando todas as informações de que já falamos (nome das notas, intervalos e modos) e o segundo servirá para fechar esta mesma árvore, ficando visível apenas o nome dos acordes encontrados. Existem alguns acordes não tão usuais, que podem não ser achados em campos harmônicos tradicionais. Neste caso, o Cifracil não teria como identificar este acorde. Mesmo assim, você poderá cadastrar o acorde, caso entenda de harmonia e saiba dar o nome do acorde. Apenas tenha o cuidado de observar as Regras para reconhecer acordes no texto para que o Cifracil consiga interpretar o nome do acorde corretamente. Colocando o nome adequado você poderá cadastrar o acorde na caixinha de edição com titulo Nome do Acorde e clicando em siguida no primeiro botão (figura 6, logo acima). Como já explicado acima, este botão transferirá o nome do acorde para o acorde que você desenhou, bastando apenas salvar o acorde, clicando no botão com o Disquete, na tela anterior (figura 5).


Regras para reconhecer acordes

Como já afirmamos, ao explicar a funcionalidade do botão de interpretação de textos do , Editor do Cifracil, não existe uma padronização mundial para dar nomes aos acordes nos textos cifrados. Para que o Cifracil consiga interpretar o texto, identificar um acorde, tivemos que adotar uma padronzação. São essas as regras que estamos explicando neste tópico. Procuramos adotar uma nomeclatura mais próxima possível das obras do famoso autor brasileiro Almir Chediak, autor do livro Dicionario de Acordes Cifrados. Vamos as Regras:

1) O acorde deve começar com uma letra maiúscula de A-G (La,Si,...Sol). Logo em seguida podemos ter opcionalmente os símbolos # ou b (sustenido ou bemol).

Ex: A# B Db

Tome cuidado ao utilizar os simbolos # ou b logo depois da Fundamental, visto que eles também podem estar sendo utilizados em intervalos como #4, por exemplo. Veja este caso:

Se você escrever C#4, o cifracil terá de saber se o sustenido pertence ao intervalo, neste caso de quarta aumentada #4, ou se você quis dizer que o sustenido é da fundamental (Tônica), neste caso seria Dó#. Utilize o parêntese para separar o intervalo da Fundamental. Neste caso você poderia utiliza-lo de duas maneiras: C(#4) = Dó com Quarda Aumentada (neste caso o # é para caracterizar o intervalo de Quarta Aumentadada) ou C#(4) Dó sustenido com Quarta (O sustenido está na nota Fundamental).

2) Não deixe espaço em branco no meio do nome da cifra: Ex: C7 9. Para separar os intervalos não utilize espaços em branco. Utilize parênteses ( ) , barra / ou ponto . para serara-los. Ex: G7(9) G7(9/13) G7(9.13)

3) Utilize apenas os símbolos abaixo (que representam intervalos) quando for escrever o nome de um acorde:

Intervalo Descrição Simbolo Utilizado Exemplos

----------- ------------------------- -------------------------- -----------------------------------------------------

2m Nôna menor b9 C7(b9)

2M Nôna maior 9 C7(9)

2aum. Nona Aumentada #9 C7(#9)

3m Terça Menor m Cm

3M Terça Maior Não informar C = Dó Maior

4j Quarta Justa 4 ou sus4 ou 11 C4 ou Csus4

4aum Quarta Aumentada #4 ou #11 C(#4) ou C(#11)

5 dim Quinta Diminuta b5 Cm7(b5)

5 aum Quinta Aumentada #5 C(#5)

6m Sexta Menor b6 ou b13 C7(b6), C7(b13)

6M Sexta Maior 6 ou 13 C6 ou C13

7 dim Sétima Diminuta ° ou dim C°

7 Sétima (menor) 7 C7

7M Sétima Maior 7M ou Maj7 C7M ou CMaj7

Qualquer outro símbolo utilizado para montar o nome de um acorde será rejeitado pelo Cifracil. Por exemplo: C- (Dó menor), embora seja muito utilizado também nos métodos de cifragem não será reconhecido pelo Cifracil.

Observação: O Cifracil desenha a digitação dos acordes, e em varias telas mostra as notas e os intervalos dos acordes abaixo da ultima casa da digitação. Resolvemos representar o intervalo de Sétima diminuta com 7d em vez do simbolo bb7, que seria mais correto. No entanto assim o fizemos por uma questão de espaço ocupado pelo símbolo bb7. 7d ocupa menos espaço do que bb7, e como o espaço entre as cordas é pequeno achamos por bem, para que o símbolo bb7 não fosse sobrescrito pelos símbolos das cordas visinhas, utilizarmos 7d, que é mais compacto.

4) A nota do baixo de um acorde deve sempre ser precedida por uma barra /. Ex: C/G

5) Você poderá utilizar o símbolo * no final do nome do acorde com o objetivo de diferenciar digitações diferentes para um mesmo acorde em seu documento no Cifrácil.. Ex: E(Primeira digitação encontrada no seu documento) E* (Segunda digitação) E** (Terceira digitação). Embora estes três acordes sejam Mí Maior, cada um poderá estar sendo tocado com uma digitação diferente em trechos da música cifrada. Ao utilizar esta convenção ( o asterisco ), quando o Cifracil interpreta o texto, estas três digitações, utilizadas como exemplo, aparecerão como se fossem acordes distintos na aba Repositório de Acordes. A partir daí basta que você modifique cada digitação através do botão Modificar Digitação Acorde Selecionado, já que os três acordes em questão aparecerão com a mesma digitação no momento da interpretação. Isto acontece porque o Cifracil pega sempre os acordes com digitação definida como Default.

6) Poderá utilizar cifragem com subscrito e sobrescrito. Basta ir no Menu Principal, e entrar na opção Configurações e em Seguida Página de Impressão.

Se marcar a opção Usuar Subscrito nos Acordes na Pagina de Preview, fará com que o Cifracil na montagem da pagina de preveiw do documento transforme em subscrito acordes do tipo X a/b, onde a é o subrescrito e b o subscrito. Exemplos para estes acordes: A7/4. A regra é muito simples ao utilizar / o cifracil entende que você está querendo fazer sobrescrito com o elemento a esquerda da barra e subscrito com o elemento a direita então no nosso exemplo temos A7/4 transformará em A (fará sobrescrito no 7 e subscrito no 4). Se separar os intervalos utilizando um ponto . o cifracil não fará subscrito Ex: A7.4 (não terá subscrito).

Há alguns cuidados que deverá tomar.

Imagine o acorde A7/4/9 o Cifracil interpretará assim:

A (sobrescrito 7, subscrito 4, sobrescrito 4 e subscrito 9) , gerando uma formatação erronea.

Reescreva este acorde assim: A7(4/9) então o Cifracil fará: A7 (Sobrecrito 4 e subscrito 9) assim está correto, ou escreva A7/4(9) ou A7/4.9 e o Cifracil fará: A Sobrescrito 7 subscrito 4 (9)

Outra coisa a evitar. Quando tiver duas sequencias de subscritos o parenteses deve ser usado da seguinte forma: Ex: A(7/4.9/13) ou A7(4/9.13) ou A7(4.9/13), não utilize A7/4(9/13), pois o cifracil não pegará o parêntese inicial.

Lembre-se as regras da / para subscrito só valerão se a opção Usar Subscrito nos Acordes estiver marcada.


Trabalhando com Diferentes Afinações

O Cifracil permite você trabalhar com diferentes afinações do cavaquinho. A partir da versão 1.2 do Cifracil, cada afinação poderá estar associada a um dicionário de acordes daquela afinação. Na instalação do produto é instalado em sua maquina o dicionário Padrão ou Standard, contendo os acordes da afinação D G B D. Tambem geramos um dicionario na afinação D G B E baseados na afinação Padrão D G B D e esta ja vém pronta junto com a afinação padrão. Deixamos cadastrado outras afinações, porém o dicionário delas ainda não existe fisicamente. Você poderá gerar um dicionário para qualquer afinação, menos a Standard. Basta clicar no botão Gerar Dicionário (da tela Afinações, onde se cadastram as afinações) e o Cifracil gerará um dicionário para a afinação corrente (aquela que você está posicionada no seu cadastro de afinações). Se você escolheu em Forma de Geração, a opção Dicionario Vazio, é porque voce quer apenas gerar os arquivos fisicos do dicionario, e você mesmo ira cadastrar todos os acordes desta nova afinação. Se tiver marcado a opção Dicionario Transposto, ele vai tentar transpor todos os acordes da afinação corrente para a nova afinação. Este dicionário será gerado fisicamente no diretorio abaixo da aplicação. Geralmente o c:\Arquivos de Programas\Cifracil\Dicionarios. Lá, cada dicionário possui tabelas com o nome da afinação que caracteriza o dicionário. Ex: As tabelas que compõe o dicionário da afinação padrão tem nome D G B D + algumas extensões próprias do Software. Quando o cifracil gera um dicionario Transposto, ele o faz da seguinte forma: Todos os acordes da afinação Standard são lidos e transformados para digitações da afinação que está sendo gerada. Na geração do dicionário pode acontecer que o tamanho do dicionário gerado seja menor do que o dicionário standard. Porque ? Porque quando geramos novas digitações, a partir de digitações da afinação Standard, pode acontecer que algumas digitações calculadas sejam despresadas. São elas: 1) Digitações que ao serem calculadas geraram acordes com notas antes da corda solta ou geraram digitações com uma extensao de + de 5 casas, o que tornaria esta digitação impossível de ser feita por qualquer instrumentista. A não ser que fosse um instrumentista que utilizassem tecnicas para digitar o acorde com duas mãos, como o guitarrista Stanley Jordam faz, por exemplo. É importante ressaltar que o Cifracil só permite trabalhar com um dicionário, correspondente a uma afinação, por vez. Ou seja, o Cifracil abre somente um dicionário de acordes para você trabalhar com ele, seja fazendo documentos com aquele dicionario, ou pesquisando um acorde no dicionário. Quando o Cifracil é aberto, se você ainda não abriu qualquer documento o Cifracil abre o dicionário da afinação Standard. Se você abrir um documento qualquer e não houver ainda nenhuma música aberta, a afinação corrente será a afinação do documento aberto. Caso você esteja abrindo um documento que não tenha o dicionário correspondente a esta afinação, gerado em sua maquina, o Cifracil cancelará a abertura do documento. Basta que você cadastre esta afinação e gere o dicionário para ela e então poderá abrir o documento normalmente. Já que não podemos trabalhar com varios dicionarios abertos ao mesmo tempo criamos um botão na barra de ferramentas do Cifracil {bmc Braco.bmp} para que você possa trocar o dicionário aberto no momento para um dicionário de outra afinação.

Clicando neste botão uma janela será mostrada, como você pode ver na figura abaixo, com as afinações que possuem dicionários gerados para ela. A linha marcada de azul mostra o dicionário aberto na afinação correspondente. Se você quer trabalhar com documentos de outras afinações, ou deseja pesquisar o dicionário de acordes desta outra afinação, basta clicar na afinação mostrada e o dicionario atual será fechado, abrindo em seguida o dicionário da nova afinação escolhida por você. Lembre-se de que as afinações mostradas aí seráo somente aquelas afinações que você já gerou dicionario para elas. Se você cadastrar uma afinação e não gerar o dicionário dela, o Cifracil não mostrará a novar afinação na lista de afinações da janela abaixo. Frisando mais uma vez: Quando você escolhe uma afinação corrente, você está abrindo um dicionário com acordes daquela afinação. Qualquer novo documento aberto estará sendo feito com a afinação corrente. Se você entrar na tela do dicionário, os acordes mostrados serão os da afinação corrente.


Importando uma Música para o Cifracil

A Internet, hoje em dia, tem uma quantidade muito grande de sites contendo músicas cifradas. É muito provável que você queira pegar uma música destas num destes sites e deseja passa-la para o Cifracil. Utilize a área de transferencia do Windows. Após encontrar uma música bacana em um site, basta marcar-la com o mouse, e em seguida, pressionar as teclas Control (Ctrl) + a tecla C simultaneamente, para que você possa copiar a música para a área de transferencia do Windows. Feito isto, abra um novo documento no Cifracil e cole o texto no editor utilizando o botão colar. Você também poderá utilizar a tecla Control (Ctrl) + a tecla V para colar o texto no editor do Cifracil. Se a sua musica não está na Internet e sim num editor de textos qualquer, como o Word, por exemplo, você poderá transferi-la para o Cifracil utilizando o mesmo processo explicado acima.

Dica: Ao colar um texto vindo da área de transferência do windows, utilize o botão Substituição Texto por Padrões (clique o botão pesquisar (binóculo) no editor), para que ele converta o padrão de cifragem utilizado no texto para o padrão de cifragem (nome dos acordes) adotada pelo Cifracil. Desta forma você estará preparando o texto para ser interpretado corretamente pélo software.

Além de poder utilizar a área de transferência do Windows, você poderá importar documentos cifrados em outros formatos, basta criar um novo documento e utilizar o botão localizado na barra de ferramentas do editor para importar suas músicas cifradas vindas de arquivos no formato .DOC (Ms Word), Texto (.TXT) ou Rich Edit (.RTF). Ao importar um arquivo em um destes formatos, o Cifracil fará o seguinte com o texto importado:

1. Retirará o Tab (no caso de ter utilizado a tecla de tabulação Tab do editor);

2. Converterá a Cifra, trocando o nome dos acordes utilizados para o padrão de interpretação de acordes do Cifracil, utilizando a Tabela de Padrões de Cifra, cadastrada no Cifrácil. (veja no help quando fala sobre o editor, a explicação dada para o botão Tabela Padrões Cifra, que aparece ao clicar o botão de pesquisa (representado por um binóculo).

3. Aplica no texto a formatação dada na Palheta de Estilos do editor.

4. Interpreta os acordes do texto, localizando-os no dicionário de acordes.


Criar ou Editar Songbooks

Se você ja dominou bem o funcionamento da criação de documentos no cifracil, já sabe utilizar o editor, criar suas musicas e salva-las poderá agora aprender a criar um livrinho de musicas, um songbook. Se ainda não domina bem estes conceitos recomendamos não ler ainda este tópico.

Deverá então estudar antes como Criar ou Editar um Documento no Cifracil. Mantivemos as explicações e figuras do help cifracil violão por ser identico a forma de trabalhar, mudando apenas que os arquivos utilizados para montar o dicionário serão no formato do Cifracil Cavaquinho (.cfc)

Após aprender a criar documentos no Cifracil, é possível que você fique pensando numa maneira de organizar seus documentos já elaborados no programa. Que tal você poder juntar suas musicas em um único documento ? É muito comum você querer ter em um documento somente, varias musicas de um determinado artista. Ou ainda varias musicas que você toca em um repertório específico que você criou para tocar na noite por exemplo.Também poderá ter cifrado todas as musicas de um determinado Cd de seu artista ou banda preferida. Que tal juntar isto em um livrinho de musicas feito no Cifracil ? Pois bem, o Cifracil permite voce juntar varios documentos ja feitos no cifracil, suas musicas cifradas no formato do Cifracil (Arquivos .cfr) em um documento único, em um livro de musicas, ou um songbook. Um Songbook é então um pequeno livro com músicas selecionadas por você. Criamos no Cifracil um cadastro para você poder gerar songbooks. A ideia é você poder cadastrar para cada songbook que deseja criar, um conjunto de informações que permitirão o software gerar um preview (uma pagina de visualização) do seu songbook, contendo uma Capa, um índice contendo os titulos das musicas e páginas respectivas, e as músicas escolhidas por você. Após você cadastrar as características que terão o seu songbook, basta clicar um botão e o Cifracil gera um preview com todas as paginas do seu songbook. Você poderá folhear todo o seu songbook e clicando em mais um botão o livrinho gerado será salvo em um unico arquivo, no formato .prv (preview). (Nas versoes anteriores a 2.1, o formato que era salva era o .snb (songbook). A partir da versao 2.2, este formato mudou para o .prv (Preview) Uma vez salvo o arquivo do songbook gerado, poderá abri-lo quando desejar. Vamos agora explicar mais detalhadamente como tudo isto funciona. O Cadastro de SongBooks pode ser acionado clicando no botão que tem um livro azul desenhado, localizado na barra de ferramentas .

Para facilitar o aprendizado vamos montar um songbook passo a passo, sem entrar em todos os detalhes de configuração primeiramente. Vamos gerar rapidamente o songbook para você ver como é fácil gerar um songbook no Cifracil com poucos passos. Após aprendermos a gerar um songbook, iremos aprofundar em todas as possíbilidades de configuração do seu songbook que permitirão a você personalizar o songbook gerado bem ao seu gosto pessoal.

Mãos a obra companheiros ! Convido você a seguir comigo os passos para gerar um songbook.

8 Passos para criar um songbook rapidamente

1) Você precisará de ter as musicas cifradas feitas no Cifracil. Ou seja terá que ter arquivos com extensão .cfr, criados no Cifracil. Sem ter seus arquivos .cfr criados não vale nem a pena começar o serviço.

2) Clique no primeiro botão mostrado na figura abaixo para criar um novo songbook.

3) Tenha sempre em mente que o Cifracil oferece para você a oportunidade de criar um banco de dados contendo informações que o programa utilizará para gerar os songbooks criados por você.

Portando ao criar um novo songbook você está adicionando ao seu banco de dados de songbooks, mais um songbook para sua coleção.

Digite o Título que identificará seu songbook no banco de dados, como mostrado na figura abaixo.

Quando for pesquisar os Songbooks no seu banco de dados será mostrado este titulo dentro do cadastro de songbooks.

4) Clique no botão Adicionar Musicas , mostrado na figura acima. Este botão permitirá você navegar nas pastas, ou diretórios, onde se encontram as músicas que você quer colocar no songbook. Todas elas devem ter sido feitas no editor de textos do Cifracil. São os documentos no formato do Cifracil, os arquivos com extensão .cfr

Veja a tela abaixo:

Escolha a pasta dando duplo clique na pasta Aqui são mostrados todos os arquivos

onde estão as suas musicas que deseja incluir no formato cifracil contidos na pasta

no songbook. corrente. As musicas marcadas serão

as musicas que você quer colocar no

songbook. Os botões Marcar todos e

Desmarcar todos poderão nos auxiliar.

Clicando com o mouse sobre a marquinha ao lado esquedo da musica, você estará marcando e

desmarcando a musica. Vamos deixar marcados somente as músicas Aqui Oh, Bons Amigos, Beijo Partido e Litoral. E vamos clicar no botão Incluir Músicas na seleção. Se quisessemos escolher outras musicas em outras pastas bastaria navegar em outras pastas, escolher mais musicas e clicar novamente no botão Incluir Músicas na Seleção. É como se estivessemos fazendo compras. As pastas ou diretórios são as prateleiras e as músicas os produtos. Cada vez que escolhessemos os produtos teriamos que coloca-los no carrinho de compras , ou seja no botão Incluir Músicas na Seleção. Pois bem ao clicar neste botão verá a seguinte mensagem:

Clique na aba com o título Músicas selecionadas para Inclusão e verá a tela abaixo:

Aqui aparecem todas as músicas que você selecionou

A ordem em que as músicas aparecem na telá, a priori, será a ordem em que elas serão geradas

no seu songbook. Se quiser modificar esta ordem poderá clicar em cima de uma musica e utilizar as setas vermelhas para cima e para baixo para trocar as músicas de lugar uma com a outra.

Antes de incluir as músicas no songbook, poderá fazer com que para todas as músicas inseridas no songbook seja colocado o tipo de preview informado e a opção de Comerçar com as digitações (desenhar as digitações logo apos o autor da música). Estes valores poderão ser modificados após incluir as músicas no songbook, é apenas um recurso de inicializar estes campos com um valor default.

Finalmente poderemos clicar no botão Incluir documentos no songbook.

Confirme a inclusão das músicas e verá que voltou para a tela de cadastramento de songbooks

vendo as músicas que você inseriu no songbook, relacionadas no songbook.

5) Vamos configurar a Capa do SongBook. Clique na aba com titulo Capa do Songbook.

Preenchemos o Título do SongBook, que sairá no início da capa.

O Subtítulo pode ser um texto complementar, como por exemplo, Volume I, Nome do Autor do Songbook, algo parecido.

O Pequeno texto, é um espaco maior para colocar algum texto falando sobre o songbook, qualquer coisa que possa ser escrito em algumas poucas linhas.

Para colocar a imagem na capa do songbook basta clicar no botão com uma figura de um homem andando. Você poderá escolher um bitmap qualquer em uma pasta do seu microcomputador.

6)

^-- Aqui voce clica e grava o songbook.

É importante gravar os dados que você já configurou para seu Songbook. Agora que você já confirou as principais características do songbook poderá gera-lo. Clique no botão gerar um songbook e aparecerá a seguinte janela:

Poderá optar por gerar o song colorido ou preto e branco.

Quanto ao Tipo do documento deixe primeiramente marcada a primeira opção,

Gerar Songbook na tela para salva-lo no formato Preview (.prv)

Clique no botão OK e o Songbook começara a ser gerado. Uma barra de progresso será mostrada após a confirmação da geração do song.

Espere chegar em 100 % (Se quiser interromper a geração do songbook poderá clicar na tecla Esc e aguardar alguns segundos. Uma mensagem de confirmação para abandonar a geração será mostrada. Poderá abandonar a execução).

A tela de preview, igual a tela mostrada no editor para visualizar a impressão de uma música será mostrada.

7) Veja o songbook gerado:

8) Utilize os botões de navegação do preview para ir passando para as próximas paginas.

Veja que o Cifracil gerou um indice com o nome das musicas e paginas onde elas estão.

Logo em seguida verá as músicas. Agora é muito importante você salvar o songbook clicando

no botão com um disquete. Aparecerá uma janela como mostrado na figura abaixo.

Coloque o nome do arquivo, no nosso exemplo: toninho e ao clicar em salvar você estará salvando o documento no formato .sbn (songbook). É muito importante você perceber a diferença entre o cadastramento do songbook e a geração do songbook enquanto documento. Você faz o cadastramento do songbook para que você possa gerar o documento songbook sempre que necessario. Gerado a visualização do songbook você então salva este resultado em um arquivo no nosso formato com extenção sbn (songbook). Este é o documento Songbook. A partir daí você pode abrir o documento songbook, o arquivo no formato songbook, que no nosso exemplo é o toninho.sbn

Depois que você salva um arquivo no formato .prv (preview) você poderá abri-lo no Cifracil. Colocamos um botão dentro da tela de cadastro de songbooks com o desenho de um livro aberto, intitulado de Ler Arquivo Songbook. Clicando neste botão será aberta uma caixa de diagolo para você escolher o songbook a ser aberto. Vá até a pasta onde salvou o seu documento no formato preview (Arquivos com extensao prv) e clique no arquivo salvo e no botão Abrir. Para facilitar sua vida colocamos um botão na barra de ferramentas com o mesmo ícone do livro aberto, assim se você somente deseja abrir um songbook, não será necessário ter que entrar no cadastramento de songbooks, onde você cria e gera um songbook, para abrir um songbook já gerado. Quando um songbook é gerado, repare que a tela onde ele é visualizado é a mesma tela de preview utilizada quando você abre um documento qualquer feito no Cifracil. Então você poderá passear pelas páginas, imprimir o songbook, da mesma forma como faz quando cria uma musica cifrada no Cifracil. Também poderá imprimir o songbook, direcionando a saída de impressão para um arquivo no formato PDF. Os arquivos no formato PDF podem ser lidos utilizando-se do programa Acrobat Reader, que é freeware e pode ser baixado facilmente da internet. Este formato é muito interessante, pois pode ser aberto até nos computadores Mac da Apple. É muito bom poder gerar um songbook no formato PDF para enviar para algum amigo que ainda não tenha o Cifracil. Para saber como direcionar sua impressão gerando arquivos pdf, e ter maiores detalhes sobre o funcionamento da tela de preview clique aqui

É importante ressaltarmos que ao gerar um songbook, você não necessariamente precisa salva-lo para poder imprimi-lo. Mas achamos interessante você salvar o documento songbook, para não ter que regera-lo toda vez que quiser ver o seu songbook. Você só precisará gerar um songbook novamente se você modificar, inserir ou apagar alguma música que faz parte de um songbook já gerado anteriormente.

Agora que você já sabe gerar um songbook no Cifracil vamos ver como poderemos personalizar mais os songbooks a serem gerados analisando detalhadamente todas as possibilidades de configuração disponíveis no nosso cadastro de songbooks.

Parte superior da Tela de Cadastro de Songbooks

A todo momento você poder ver qual é o songbook corrente, pois o título do songbook é mostrado, como no nosso exemplo "Tributo a Toninho Horta"

Usado para criar novo songbook no cadastramento de songbooks.

Deve ser utilizado para colocar os campos do songbook disponíveis para serem alterados.

Portanto se for alterar qualquer característica de configuração do songbook, com exceção, das músicas do songbook, você deve clicar este botão e após efetuar as modificações no songbook deverá grava-las utilizando o próximo botão.

Gravar novo songbook ou alterações efetuadas em um songbook que você está alterando.

Apaga o songbook atual. Lembre-se que você está apagando somente o cadastramento do songbook do seu banco de dados. As músicas .cfr contidas no songbook continuarão intáctas, bem como o documento songbook da música em questãõ, se já tiver sido salvo em disco.

Cancelar um registro de songbook novo ou que está sendo alterado.

Permite você navegar no cadastro de songbooks, mostrando o songbook anterior (primeiro botão) ou o proximo songbook (segundo botão) cadastrado. Ao fazer esta navegação poderá constatar que o título do songbook mostrado vai se modificando no topo da tela.

Após o cadastramento das caracteristicas de configuração de seu songbook estiver todo pronto poderá utilizar este botão para fazer o Cifracil gerar um documento que terá la dentro seu songbook completo (capa, indice, e as musicas).

Você poderá ter seu documento Songbook gerado em dois tipos de formatos a escolher.

Ao Clicar neste botão aparecerá a seguinte janela:

Poderá gerar seu songbook Colorido ou Preto e Branco. Se voce escolher a opção Preto e Branco e a imagem da capa escolhida ja tiver cor, o cifracil não mudará a imagem em nada, apenas escreverá os textos e desenhará os acordes em preto e branco.

Como ja falamos acima o Documento do Songbook Gerado poderá estar em dois formatos:

A primeira opção irá gerar um documento no formato Preview(.prv), que é um formato criado pelo nosso software.(Este formato entrou no lugar do formato .snb (songbook) utilizado na versao 2.1) Nesta opção o Cifracil primeiramente gera um preview do songbook e então depois de voce visualiza-lo na tela poderá clicar no botão que contém um disquete [image] para salvar o documento no nosso formato .snb. Neste momento voce irá informar o nome do arquivo a ser salvo e o cifracil o salva rapidamente em disco. Estes arquivos são grandes, mas se compactados diminuim muito o seu tamanho.

Na Segunda opção (Gerar Songbook no formato PDF), o cifracil não gerá um preview do songbook. Neste caso, ao clicar no botão OK o cifracil abrirá uma caixa de dialogo para voce colocar o nome do arquivo (sem extensao) a ser salvo, e a pasta se desejar. E então o cifracil ira gerar o documento PDF. A Geração do PDF é mais demorada do que a geração do songbook na tela de preview (primeira opção), mas consideramos o PDF um formato muito bom. Voce poderá manda-lo para outras pessoas que inclusive tenham até sistemas operacionais diferentes como o Mac. Também gostariamos de ressaltar que o indice das musicas gerados, no arquivo pdf tem uma caracteristica de link. Ou seja, ao voce clicar no nome da musica, dentro do acrobat reader (o programa freeware que abre documentos pdf) o Acrobat Reader leva você até a pagina da música.

O Acrobat Reader pode ser baixado da internet no link http://www.adobe.com/products/acrobat/readstep2.html

Também gostariamos de ressaltar que alguns usuarios tiveram alguns problemas de impressão, devido a incompatibilidades de alguns drivers de impressão, com nosso componente de geração das paginas do preview, e para estas pessoas a opção de se gerar um PDF é muito boa, pois eles podem gerar o PDF e imprimi-los atraves do Acrobat Reader.

Em ambas as opções de geração descritas acima, após você confirmar o início do processamento para gerar o songbook uma barra de progresso será mostrada. Ao atingir 100% seu songbook será mostrado no preview e poderá imprimi-lo ou salva-lo se escolheu a primeira opção quanto ao tipo de documento gerado ou então mostrará o nome do seu arquivo pdf gerado e poderá clicar no botão com o titulo Fechar.

Este botão é a razão de ser deste cadastramento. Cadastramos a forma com que o Cifracil gerará o songbook, informando a ele todas as características desejadas para finalmente termos o produto final, um documento songbook salvo em disco, com duas opçoes de formatos (.snb ou pdf)

Após gerar o songbook e salva-lo em um arquivo no formato preview .prv você poderá carragar para a tela de preview o documento songbook salvo. Ao clicar neste botão basta escolher um arquivo no formato songbook e abri-lo. Também colocamos na barra de ferramentas um botão que faz a mesma coisa, evitando que a pessoa tenha que entrar no cadastramento de songbooks somente para ler um arquivo do songbook salvo no formato .prv (preview)

Após configurarmos um songbook inteiro é possível que queiramos manter um padrão de estética que combina com nosso estilo pessoal. Portanto se você fez um songbook que tenha gostado dele, estéticamente, poderá salvar quase todas as caracteristicas de configuração das abas Capa Songbook, Indice, Configuracao de Página já feitas para um songbook corrente. Desta forma, ao criarmos um novo songbook o Cifracil inicializa uma serie de campos de configuração do song com os padrões que você salvou utilizando este botão. Isto poupa um enorme trabalho para criar songbooks com um aspecto igual a outros já feitos. Um exemplo seria você sempre querer que o título dos seus songbooks fossem sempre configurados com o Fonte Arial , tamanho 16, cor Azul. Ok, basta clicar neste botão, após você já ter feito um songbook com esta característica e toda vez que for criar um novo o Cifracil irá setar o fonte do título da capa com as características já citadas.

Nossa tela de cadastramento de songbooks é dividida em abas ou paginas. Vamos ver cada uma detalhadamente.

A primeira delas é a aba Consulta. Como já dissemos ateriormente, o cadastramento de songbooks é na verdade um banco de dados de songbooks. Cada songbook que você vai salvando no seu cadastro vai entrando como mais um songbook para seu catálogo. Então nesta aba Consulta, você poderá ver a lista de songbooks já cadastrados por você. E poderá localizar um determinado songbook a medida que for digitando o nome dele na caixinha onde há o título Pesquisa por Título do Songbook O songbook corrente é sempre o que estiver com uma setinha antes do título, como mostrado no exemplo acima. Se você quer modificar ou apenas ver o seu cadastramento realizado para um songbook, basta localiza-lo nesta aba e todas as informações mostradas nas outras abas serão referentes ao songbook corrente, o que tem a seta para o título.

Segunda Aba:Músicas Songbook

Esta tela pode ser dividida em 3 partes:

1) Onde vemos Titulo SongBook, o botão Adicionar Músicas e opção de Ordenação das músicas

1.1) O Título do Songbook, é o título que identifica o songbook no seu banco de dados. É através deste título que podermos localizar um songbook na aba Consulta, explicada anteriormente.

1.2) Botão Adicionar Músicas, já foi explicado acima o seu funcionamento quando falamos no passo 4 como gerar um songbook. Este botão permite você escolher as musicas ja feitas no formato do Cifracil, que comporão seu songbook.

1.3) Ordenar Digitações por, é para informar ao Cifrácil sua opção de como as digitações, os desenhos dos acordes aparecerão nas músicas do songbook. Poderá ver as digitações na ordem que aparecem no texto ou em ordem alfabética.

As partes 2 e 3 da tela representam as músicas que compõe o songbook.

Observando podemos ver uma grade contendo todas as músicas do song (parte 3) e na outra parte podemos ver com detalhes cada música que está em forma de grade. (parte 2).

São duas formas de enchergar a mesma informação, só que a grade serve apenas para visualizar as musicas e para colocarmos uma determinada música como música corrente, para alterarmos alguma característica dela em relação a geração do songbook.

Os Campos música e Caminho do Documento, não podem ser alterados diretamente. Como já vímos antes as músicas que estão no songbook foram inseridas através do botão Adicionar Músicas. Se desejar colocar mais alguma música que tenha escolhido no songbook basta acionar este botão. Mas você poderá trocar a pasta da música caso tenha transferido ela de lugar clicando no botão [image] É bom evitar ficar trocando suas músicas de lugar, se não quiser ter que trocar o diretorio delas no cadastramento do songbook. Organize-se, crie uma estrutura de pastas que você não mexa nelas.

Os campos abaixo serão responsáveis pelo forma com que o Cifracil gerará o documento no songbook. Poderá configurar como cada música será gerada no preview do songbook. Na verdade são as mesmas opções oferecidas quando você clica no botão para visualizar a impressão de um documento dentro do editor do Cifracil.

O Campo Ordem do documento no Songbook, indica a ordem que ele ocupará no songbook gerado. Pode ser que você queira inverter a ordem de duas músicas no songbook. Basta colocar a ordem correta que deseja que as músicas apareçam no song e quando ele for gerado, irá colocando as músicas no preview de acordo com esta ordem.

O Campo Mostrar Afinação, quando marcado indica que você quer mostrar a afinação do documento no início da música.

O Campo Começã com as digitações se marcado, fará com que o Cifracil coloque os desenhos dos acordes (digitações) logo após o Autor da música.

Tipo de Preview, você deve indicar se a música corrente do songbook será feita no modo colunar ou não colunar (estes modos já estão bem explicados quando explicamos o funcionamento do Editor do Cifracil do Cifracil.

Com os botões acima da grade das músicas poderá realizar as mesmas ações explicadas em relação aos mesmos botões utilizados para dar manutenção no seu songbook:

Clique nele para que possa alterar uma alguma das características relacionadas com a música corrente.

Grave as alterações efetuadas na música.

Apagar a música corrente do songbook.

Cancelar uma alteração em curso, antes de clicar no botão gravar.

Navegar entre as musicas do songbook. Também poderá navegar clicando na música dentro da grade.

Aqui você poderá planejar como será sua capa do seu songbook. Imaginamos que uma capa de songbook deveria ter os seguintes elementos:

1) Título: Será o título que representará o songbook

2) Subtítulo (indicando autor por exemplo)

3) Imagem uma imagem que provavelmente ficará no centro da página (pode ser a imagem de um cd ou artista que represente o songbook)

e finalmente um

4)Pequeno Texto, imaginei um espaço para digitar algum texto complementar em poucas linhas, informando qualquer coisa, endereço para contato, telefone, algo que explique o songbook, qualquer coisa que se queira dizer em poucas linhas.

Cada um destes elementos possui duas características a configurar:

1) O fonte a ser utilizado. Padronizamos um botão para configuração do fonte (padrão de letra) que será utilizado nas demais partes do song. Toda vez que ver o botão [image] é sinal que poderá configurar o Nome do Fonte, tamanho, cor , negrito, italico, normal para o elemento em questão.

Ao escolher uma configuração de fonte mostramos na tela o nome do fonte, tamanho e pintamos o título do elemento em questão com a cor escolhida por este botão. Atenção: Este botão estará apenas habilitado quando você estiver inserindo um novo songbook ou tenha clicado no botão de alteração do songbook, ja mostrado mais acima.

2) Posicionamento do elemento na página de preview. Poderá por exemplo, configurar a altura onde a imagem que você colocou na capa ficará posicionada na página do song gerado.

Quando falamos de Altura do Título, Subtítulo, Imagem e Pequeno texto estamos nos referindo a valores que podem ser modificados para posiciona-los mais para cima ou mais para baixo.

A todo momento poderá clicar na aba Visualizar Capa para ir vendo se os valores colocados por você nos campos Altura Titulo, Subtítulo, etc estão posicionando estes elementos como deseja.

Tudo que você está configurando para aparecer na capa será posicionado para aparecer centralizado.

No momento de posicionar os elementos cuidado para não colocar valores muito acima de 250, se fizer isto você poderá estar colocando o elemento configurado para fora da área de impressão da página.

Para colocar uma imagem basta clicar no botão [image] e escolher o bitmap para colocar na sua capa. Este botão fica desabilitado caso não esteja inserindo ou alterando o songbook.

O Título do Indice refere-se a paravra que você quer a aparece na primeira página do Índice de músicas gerado pelo Cifracil. Poderá colocar por exemplo :Musicas do Songbook ou Índice,etc

Também poderá configurar o fonte desejada utilizando o botão com um A, já explicado antes.

A Altura deste título na pagia também segue a ideia de posicionar mais em cifra ou embaixo o local onde aparecerá o Título do Indice.

A Altura da Primeira Música no Índice, serve para posicionar onde começaram a ser escritos os títulos das músicas do songbook.

A fonte utilizada para escrever as músicas do songbook é a courrier new. Só poderá configurar o tamanho a ser utilizado.

A Quantidade de Músicas na página do Índice é muito importante, pois ela definirá para o Cifracil, quantas paginas de índice seráo geradas, levando-se em conta o número de músicas do songbook.

Se você desejar que cada música seja precedida por um número com parêntese: Ex: 1) então deixe o campo numerar as músicas do índice marcado.

Você também poderá a todo momento estár clicando em Visualizar Indice, para ter uma ideia de como ficará o índice das músicas. Nesta visualização não mostro o título de cada música porque este título só será pego pelo programa ao processar o songbook. Por isto mostro apenas onde ficará o título de cada música colocando neste preview apenas o nome do arquivo será substituido pelo título real da música gerado.

Podemos configurar como será o cabeçalho e rodapé das músicas do songbook.

Ambos possuem os mesmos parâmetros de configuração. Explicaremos somente o cabeçalho já que as mesmas regras servem para o rodapé.

Exibe Cabeçalho: Quando desmarcado todo o que foi configurado no cabeçalho não será exibido.

Traçar uma Linha de cabeçalho: Se marcado traçará uma linha divisória demarcando o cabeçalho.

Título do Cabeçalho: Aqui, o que você escrever sairá no cabeçalho de todas as músicas. Poderá colocar o título do songbook por exemplo. Pode ser também que queira que saia aqui o nome da música em vez de colocar uma frase fixa. Neste caso deixe marcada a opção: Preencher com o

Título da música Se uma música ocupar mais de uma página, o título dela acompanhará todas as paginas daquela música, só irá mudar quando entrar na primeira página da próxima música.

Também clicando no botão com um A poderá configurar a fonte a ser utilizada. Escolha de preferência um tamanho pequeno.

Você também poderá escolher o alinhamento do título. Particularmente, acho o centralizado mais interessante, mas gosto não se discute.

Se deixar marcado Exibir a numeração da página então você poderá informar duas coisas:

O alinhamento, onde sairá:direita ou esquerda, e poderá colocar um título que identifica a pagina. Exemplo: Pag, Pagina, P: (opcional) Se deixar em branco sairá apenas a numeração da pagina.

Na aba Desenho do Acorde, poderá escolher qual das digitações cadastradas no Cifracil ira servir como modelo na hora de desenhar os acordes nas paginas das músicas cifradas que compõe o songbook. E Finalmente poderá também ter uma visualização aproximada da aparencia da sua página clicando na aba Visualizar Página.


Aparência do Braço

No item de Menu Principal Configurações \ Aparência do Braço você acessa esta tela.

Primeiramente veja que você pode trabalhar nesta dela de duas forma: Se na caixinha com o título Configurar graficamente, você marcar sim, quer dizer que você quer alterar a altura e a largura da cifra através das setinhas ao lado dos titulos Altura e Largura. Clicando nestas setinhas você verá graficamete a cifra ir aumentando ou diminuindo. Caso você marque em Configurar Graficamente = Não, isto significará que você digitará o tamanho da cifra Altura e Largura, em pixels. Isto pode ser útil se você fez uma configuração graficamente e deseja repassa-la para um amigo. Quando você faz a configuração graficamente, os valores Altura e Largura são gravados automaticamente para você ao clicar no botão de salvar (com o desenho do disquete). Desta forma anote os valores de Altura e Largura, mostrados na grade, na linha da configuração que você deseja passar para outra pessoa. Basta que esta pessoa crie uma configuração nova com os valores que você passar para ela e então a nova configuração ficará igual a sua.

Marcando esta opção:Configurar Graficamente = Não, também servirá para você informar outros dados importantes de configuração que está criando, que influenciarão no tamnho do fonte a ser utilizado no desenho da cifra que voce está criando.

Este botão servirá para incluir um novo modelo de configuração do braço. Se você marcou a opção Configurar Graficamente = Sim, então ao clicar neste botão voce deverá ir clicando nas setas para regulagem da altura e largura, como ja explicado acima, para ir montando um tamanho da cifra graficamente. Não se importe num primeiro momento com o tamanho do nome do acorde que ficará neste momento desconfigurado, aparecendo as vezes muito grande em relação ao tamanho da cifra, pois num segundo momento você irá configurar isto. Após chegar num tamanho da cifra que achou interessante clique no botão salvar [image] e a primeira parte apenas da configuração está pronto. Mude a opção Configurar Graficamente para Não e clique no botão de edição [image] para que voce possa alterar os outros campos que explicaremos agora, pois eles ainda não foram configurados. Neste momento aparecerá a tela abaixo:

Altura Tecla em Pixel: A Altura da Tecla a ser definida, é da tecla branca. O cifracil cria as teclas pretas usando um calculo de proporção.

Largura Tecla em Pixel: Definira a largura de uma tecla do teclado. A tamanho da largura, bem como da Altura definirão o tamanho total do teclado.

Quando você marca a opção Configurar Graficamente = Sim, os dois campos acima são configurados automaticamente, pois você ja definiu graficamente a altura e largura da cifra. Mas quando entra nesta tela, se quiser poderá modificar estes dois valores, redefinindo assim as dimensões da cifra.

Tamanho Fonte Nome Acorde: Define o tamanho do fonte a ser usudo para desenhar o nome do acorde acima a primeira casa da cifra. Este tamanho será usado em todas as telas do cifracil onde o desenho da cifra aparece, menos na montagem da tela de preview do documento. Quando o cifracil desenha o preview do seu documento para saber o tamanho do fonte a ser utilizado configure o campo Tamanho Nome Fonte Acorde Preview A esta altura voce deverá estar perguntando porque não tem apenas um campo de configuração para regular o tamanho do fonte do nome do acorde. Quando nós criamos a configuraçao com codigo = 4, haviamos configurado o fonte para tamanho 10.

Acontece que na aba onde ficam desenhado os acordes da música, dentro do editor, o nome do acorde quando era comprido, estava sendo cordado no finalzinho da cifra, mas na tela de preview do documento, o tamanho 10 ficou muito bom e não aconteceu este problema, então resolvemos criar dois campos de configuração para poder corrigir este problema. Note que nesta configuração (codigo 4) colocamos o Tamanho Fonte como 9 e o Tamanho fonte Preview como 10, resolvendo assim o problema, pois com o fonte 9 o nome do acorde não estava sendo cortado. Portanto ao criar uma nova configuração fique atento a este detalhe.

Tamanho Fonte Numero Casa: Refere-se ao tamanho do fonte utilizado para desenhar o numero de uma casa do violão a esquerda da cifra. Imagine a pestana do acorde de La maior na 5 casa. O Numero 5 deve aparecer na primeira casa do desenho da cifra. O tamanho do fonte deve ser configurado para desenhar esta informação.

Tamanho Fonte Nome Notas: Refere-se ao tamanho do fonte utilizado para desenhar o nome das notas e ou intervalos abaixo da ultima casa da cifra.

Altura Nome Acorde Preview: Esta altura é o posicionamento inicial onde o nome do acorde será escrito. Se deixa-lo zerado, pode ser que o nome do acorde fique muito em cima da cifra e sobre um bom espaço livre até a primeira casa. Leve em consideração o Tamanho do Fonte Escolhido para o nome do acorde e o tamanho da casa em pixels, isto definirá o espaco onde o nome do acorde será desenhado na cifra. Este campo também está em pixels. Alterando pois este valor o nome do acorde poderá ficar mais perto da primeira casa, se este valor for crescente, e se for um valor bem pequeno estará aproximando o nome do acorde do topo da cifra e afastando o nome em relação a primeira casa da cifra.

A opção Abaixo do braco cavaquinho, voce definirá quais informações quer mostrar na cifra.

Poderá não mostrar nada abaixo do Cavaquinho marcando a primeira opção. Poderá ver apenas o nome das notas referentes a cada corda marcando a segunda opção. E finalmente poderá ver o nome das notas e seus respectivos intervalos, marcando a última opção. Os intervalos são na verdade uma nomeclatura utilizada para mostrar a estrutura do acorde. São intervalos porque representam a distancia entre a tônica e o restante das notas.

Após configurar isto tudo basta clicar no botão Ok e os dados configurados serão salvos.

Lembramos que se você tiver clicado no botão para criar uma nova configuração e você havia marcado Configurar Graficamente = Não, então seria mostrado a tela com todos os campos que acabamos de explicar, e então bastaria informar o valor para todos os campos e salvar a configuração..

Estes botões permitem navegar entre as configuraçoes existentes.

Poderá utiliza-los para posicionar em uma opção que deseja modificar e então clicar no botão de edição [image] como ja explicamos acima, e então poderá alterar os campos desejados.

Uma das configurações será definida como default (está marcada com um X), ou seja, quando você abrir um documento a aba Repositório dos Acordes, onde são mostradas as digitaçoes, utilizará a configuração definida como default para pintar os acordes do documento na tela.

Para modificar a configuração default basta utiliza-los parando em cima da configuração que tem o X. Desmarque-a com o botãodesmarcar e clique no botão [image] e em seguida navegue até a configuração desejada para ser a default e clique no botão acima novamente para marcar o X na configuração que deseja seja a default.

Colocamos um botão com o título OK, no lado direito superior da tela, que apenas servirá para fechar a tela.


Configurando Página Impressão

Criamos esta tela para dar uma certa flexibilidade a página de visualização de impressão dos documentos do Cifracil (O Preeview). Vejamos abaixo os recursos que dispomos.

O Cabeçalho da Página, será colocado logo acima do titulo da musica, na página de preeview.

Em nossa tela de configuração, Clicando com o mouse em Exibe Cabeçalho podemos marcar ou desmarcar esta opção. Ela indica se as informações do cabeçalho serão mostradas na pagina de preview. Estas informações são basicamente duas: Numeração da Pagina e Linha demarcando o cabeçalho. Se quisermos mostrar uma linha continua logo acima do titulo da música demarcando o cabeçalho, basta marca a opção "Traçar uma Linha de cabeçalho"

Quanto a numeração da pagina, poderemos marcar se queremos que ela seja exibida ou não, bastando clicar em Exibir a numeração de Página. Se formos exibir a numeração ainda podemos escolher se o número da pagina aparecerá alinhado a esquerda ou direita.

O Campo "Título a exibir antes Numeração Página" serve para voce colocar um títuloa para a palavra página. Uns poderão preferir que a pagina saia antecedida pela palavra Pagina, outros P:, outros Pag: e aí vai, e se não quisermos que apareça palavra nenhuma antes da pagina poderemos simplesmente deixar este campo vazio.

Uma opção Interessante é a opção "Exibir título da música". Se marcado colocará no cabeçalho em todas as paginas o titulo da musica. Isto é bom para musicas que tenham mais de uma pagina, desta forma evitamos ao imprimir a música, que a pagina se confunda com paginas de outras músicas.

A sessão de Rodapé funciona identica a de Cabeçalho com a diferença que estaremos configurando a área de rodapé da página, que aparece no final da página.

Esta parte de Ajustes da área Interna foi criada para resolver problemas na montagem da página de Visualização de Impressão pelo Cifracil.

Início da Margem Esquerda: Aumentando este valor fará com que o Cifracil começa a escrever o documento de preview mais pra frente, ou seja, aumentará o espaçamento da margem esquerda da página de preview. Como sugestão poderá preencher valores de 5 em cinco como nos outros campos abaixo.

Inicio Margem Superior: Aumentando este valor fará com que o título da musica seja desenhado mais para baixo, o mesmo espacamento será respeitado nas outras paginas.

Se não quiser decer o titulo basta deixar este campo como zero.

"Aumentar espaçamento entre Linha Acordes e Linha Texto Cifrado". Se você deseja ter um espaçamento maior entre a linha de texto (letra da musica) e a linha de Acordes (cifragem, Ex: C7M Bm7, etc) poderá colocar um valor para aumentar esta distância. Recomendamos colocar valores bem pequenos (1,2,3..).

"Diminuir margem Direita em": Se você perceber que o desenho dos acordes colocados a direita da folha esta passando da margem da área de impressão da sua folha, então aumente um pouco este parâmetro. Coloque valores pequenos. Sugestões: 0,5,10,15, 20 ...

"Diminuir Margem final da página em": Aumentando este valor você poderá subir a fisicamente na página a margem interna do programa utilizada para escrever a última frase da pagina. Se você estiver perdendo o finalzinho da pagina na sua impressão, é recomendado modificar este campo, aumentando-o, para que a margem interna da página suba. Ou seja, aumentando este valor, você irá reduzir o número de linhas impressas na sua pagina, ganhando mais espaço livre no final da folha. Coloque valores pequenos. Sugestões: 10, 15, 20 ...

Clicando na Aba com titulo Configurações Subscrito e Sobrescrito vemos a tela abaixo:

Se marcar a opção Usuar Subscrito nos Acordes na Pagina de Preview, fará com que o Cifracil na montagem da pagina de preveiw do documento transforme em subscrito acordes do tipo X a/b, onde a é o subrescrito e b o subscrito. Exemplos para estes acordes: A7/4. A regra é muito simples ao utilizar / o cifracil entende que você está querendo fazer sobrescrito com o elemento a esquerda da barra e subscrito com o elemento a direita então no nosso exemplo temos A7/4 transformará em A (fará sobrescrito no 7 e subscrito no 4). Se separar os intervalos utilizando um ponto . o cifracil não fará subscrito Ex: A7.4 (não terá subscrito).

Há alguns cuidados que deverá tomar.

Imagine o acorde A7/4/9 o Cifracil interpretará assim:

A (sobrescrito 7, subscrito 4, sobrescrito 4 e subscrito 9) , gerando uma formatação erronea.

Reescreva este acorde assim: A7(4/9) então o Cifracil fará: A7 (Sobrecrito 4 e subscrito 9) assim está correto, ou escreva A7/4(9) ou A7/4.9 e o Cifracil fará: A Sobrescrito 7 subscrito 4 (9)

Outra coisa a evitar. Quando tiver duas sequencias de subscritos o parenteses deve ser usado da seguinte forma: Ex: A(7/4.9/13) ou A7(4/9.13) ou A7(4.9/13), não utilize A7/4(9/13), pois o cifracil não pegará o parêntese inicial.

Lembre-se as regras da / para subscrito só valerão se a opção Usar Subscrito nos Acordes estiver marcada.

Altura Sobrescrito e Altura Subscrito servem para você configurar a distancia entre os números que serão escritos em sobrescrito e subscrito. Ex: No Acorde A7/4 poderá colocar o 7 mais próximo ou mais distante do 4. Se aumentar o valor do sobrescrito irá colocando o sobrescrito mais em cima, neste caso o 7, e se aumentar o campo Altura Subscrito o subscrito irá descer mais, ou seja o 4 ficará mais embaixo em relação ao A e ao 7.

Algumas Configurações que achamos interessante: Altura Sobrescrito 1 e Subscrito 3 ou Sobrescrito 1 e Subscrito 2. Poderá tentar outras. É importante ressaltar que esta configuração só vale para o texto cifrado que o Cifracil desenha dentro da pagina de preview do documento.

Colocar Espaçamento após o conjunto de linhas Cifra+Acorde

Veja o Texto Cifrado abaixo:

Dm7(9) G7/4(9)

Oi coração, não dá pra falar muito não

C7M

Espera passar o avião

Em7 A7(#11)

Assim que o inverno passar

Dm7(9)

Eu acho que vou te buscar

Se colocarmos neste campo um valor maior que zero, será colocado um espaçamento entre

cada conjunto de linhas Cifra + Acorde.

Dm7(9) G7/4(9)

Oi coração, não dá pra falar muito não

Este espaco aqui pode ser maior ou menor.

Experimente alguns números tipo:2,3,4 etc.

C7M

Espera passar o avião

Em7 A7(#11)

Assim que o inverno passar

Dm7(9)

Eu acho que vou te buscar

Se não quiser utilizar este espaçamento, deixe este campo com valor zero.

Temos abaixo a explicação de dois grupos de campos:

1) Grupo de campos que estão envolvidos no retângulo com titulo Ajuste Calculo Posicionamento Acordes no preview quando utiliza subscrito

2) Grupo de campos que estão envolvidos no retângulo com titulo Ajuste Calculo Posicionamento Acordes na Geração PDF quando utiliza subscrito

Ambos explicados abaixo se repetem e tem a mesma finalidade, diferem apenas se a geração do documento esta sendo feita para PDF ou simples preview do documento.

Percentual Ajuste Posicionamento Acordes: Se você escolheu utilizar a opção que permite o Cifracil utilizar subscrito nos acordes então este campo de percentual poderá auxilia-lo a fazer leve correção no posicionamento dos acordes em relação ao texto. O que acontece é que quando utilizamos subscrito, temos que calcular o posicionamento exato do acorde em relação ao texto, escrito no seu editor, para desenha-lo na pagina de impressão. Não conseguimos nesta versão fazermos este cálculo de forma que o acorde continuasse com a posição exata, em relação a letra cifrada. O acorde ficou ligereiramente disposicionado em relação a letra, na pagina de preview ou documento PDF. Então criamos este percentual justamente para corrigir esta pequena falha de calculo. As vezes poderá perceber, dependendo do fonte que estiver configurado na sua palheta de estilos, que o acorde, ao compararmos com a cifragem que fizemos no editor, está saindo ou um pouco a esquerda em relação ao que digitamos no editor ou um pouco a direita.

Se nossa necessidade é chegar o nome do acorde um pouquinho para esquerda colocamos um percentual a ser avaliado escolhemos o campo Sentido Ajuste como Esquerda, se não poderemos fazer um ajuste a direita. Sugerimos utilizar valores pequenos como 1,2,3,4 pois percebemos que o ajuste a ser feito não costuma ultrapassar este valor. Verificamos tambem que dependendo do fonte adotado na palheta de estilos as vezes é preciso mexer neste parametro para adaptar esta distancia ao novo fonte. Esperamos corrigir este calculo em versoes futuras, inutilizando este parametro. Mas por enquanto ele pode ser importante.


Configuração MIDI

Caso seu microcomputador tenha uma placa de som instalada é possivel ouvir o som dos acordes em dois lugares:

1) No editor de textos na Aba Repositorio de Acordes, poderá clicar na em um dos acordes da lista e utilizar o botão direito do mouse, o acorde se fará ouvir imediatamente.

2) No dicionario de Acordes poderá ouvir o som de cada acorde após clicar em um botão com um sinal sonoro.

Aqui nesta tela podemos configurar este recurso midi.

Esta tela apresenta uma lista com os instrumentos Mid. Clique no Instrumento midi que deseja utilizar para ouvir os acordes tocarem no cifracil.

Em modo de ouvir o acorde configuramos como ele soará para nós.

Temos 3 tipos:

1) Todas as Notas de uma vez (todas as notas são tocadas ao mesmo tempo)

2) Destaque Baixo (Primeiro e tocado a nota do baixo e depois as outras são tocadas ao mesmo tempo)

3) Dedilhado (Você ouve uma nota de cada vez, do grave ao agudo)

Em duração da Nota poderá configurar:

Duração de Cada nota no modo Dedilhado. Se escolher o modo dedilhado, poderá aumentar ou diminuir o tempo em que cada nota irá soar.

Prolongar o som do acorde, é para que ele ao ser tocado demore mais para finalizar o som.

Modifica o Som do Instrumento Midi utilize um percentual de 0 a 100 por cento e verá o som do acorde ficar alterado, distorcido.

Efeito sustein, é um efeito que mantem a nota mais tempo quando estiver tocando a nota.

Colocamos um botão testar midi para verificar se você se os recursos midi da sua placa de som estão funcionando corretamente no cifracil. Poderá testar todos os parametros e ouvir o resultado utilizando este botão.

Finalmente, se desejar gravar as configurações testadas e modificadas basta clicar em gravar, mas se desejar cancelar os testes e voltar para as ultimas configurações gravadas clique em cancelar.


Recuperar Tabelas Corrompidas

Os dados do dicionário de acordes e as afinações ficam guardadas em arquivos magnéticos dentro do diretório de instalação do Cifracil. É possível que por diversos motivos algum destes arquivos sofram algum tipo de problema na sua estrutura física. Se aparecer no Cifrácil alguma mensagem dizendo que não foi possível abrir alguma tabela ou arquivo do Cifracil ou então a mensagem Acess Violation aparecer com frequencia, é recomendável que você acesse a opção localizada no Menu do sistema Utilitários. Aparecerá a opãção Recuperando Tabelas Corrompidas. Clicando sobre esta opção aparecedrá uma tela contendo um editor simples onde estará sendo mostrada cada etapa do processamento de recuperação das tabelas. Para começar o processo de tentativa de recuperação das suas tabelas clique no botão com o título Recuperar Tabelas. Uma mensagem será exibida recomendando que você faça um backup dos arquivos contidos no diretório do Cifracil (Geralmente C:\Arquivos de Programas\Cifracil). Assim que você confirmar o inicio do processamento, basta esperar que ele termine.

Recomendamos que você tire backup do seu dicionario de vez em quando. Basta copiar os arquivos com o nome dicionario ou seja dicionario.* Desta forma, se mesmo rodando esta rotina de recuperação, não for possivel recuperar suas tabelas, você poderá copiar seu backup por cima dos arquivos corrompidos no diretorio do Cifracil. Feito isto, basta entrar no programa novamente e tudo estará normal. Manteremos também disponivel na internet em nosso site www.atelierdavovo.com uma copia do nosso dicionario de dados, que poderá ser baixado via download a qualquer momento e subistiuido em sua maquina.


Fazer Atualização Dicionário

Para acessar esta tela você deverá acessar no menu principal Utilitários e em siguida clicar na opção Atualização do Dicionário.

A ideia desta tela é permitir que você possa estar atualizando o seu dicionario com outros dicionários disponibilizados na internet, por exemplo. Nós que fazemos o Cifracil, somos usuários dele, e temos aumentado o número de acordes no dicionário. Nossa ideia é colocarmos o dicionário em nossa página disponível, para que você possa atualizar o seu dicionário sem matar os acordes que você porventura tenha cadastrado. Você também poderá mandar seu dicionário para algum amigo que tenha o Cifracil. Ele poderá também atualizar o dicionário dele a partir do seu. Primeiramente, você deverá colocar o dicionário que deseja copiar, dentro de um diretório qualquer. (O dicionário é constituido de alguns arquivos. No diretório de Instalação do Cifracil, geralmente c:\Arquivos de Programas\Cifracil, temos o diretório Dicionarios, aí ficam os dicionários de todas as afinações que você gerou, inclusive o dicionario standard. Cada dicionario é composto por arquivos com o nome da afinação correspondente. Assim o dicionario padrão é composto de dos arquivos D G B D.*) A partir daí, basta clicar no botão Abrir Dicionário e localizar o dicionário, clicando no dicionario escolhido. Será sempre um arquivo com o nome da afinação que se deseja copiar com extensão .mti. Exemplo: D G B D.mti (para o dicionario de afinação Standard, padrão). Neste momento, o software mostrará o path do dicionário, na tela e você deverá clicar no botão Atualizar Dicionário. Neste momento uma barra de progresso irá aparecer e o processamento só terminará quando ela atingir 100 por cento. O Cifracil lê cada digitação no dicionário escolhido e verifica se você tem aquela digitação. Se não tem a digitação do acorde ela será inserida, caso contrario o Cifracil nada faz com o registro e segue para o próximo. Assim ele cadastrará apenas as digitações que você não tinha no seu dicionário. No final do processamento o Cifracil mostrará quantos acordes foram cadastrados. Neste momento você poderá fechar a tela e usar o Cifracil normalmente.


Pesquisa de Arquivos

Acessando na barra de ferramentas da tela principal o botão que tem o desenho de um binoculo voce entrara numa tela que foi feita para facilitar voce a encontrar um arquivo que voce deseja abrir no editor do cifracil ou um documento salvo no formato preview .prv

A tela é muito simples. Clique no botão Mudar Pasta para voce definir a partir de qual pasta o cifracil procurará seus arquivos. No meu exemplo coloquei a pasta c:\HP\Cifradas Isto quer dizer que o cifracil procurará em toda a estrutura de diretorios abaixo desta pasta (inclusive ela) para encontrar os arquivos que voce esta procurando.

Salve este caminho no botão Salvar pasta Inicial, assim, toda vez que chamar esta tela o cifracil ira utilizar como pasta padrão, para pesquisa dos arquivos a pasta que voce salvou. Preenchendo o campo Pesquisar Caminho Completo Arquivo Contendo a Palavra, ja diz tudo. Se voce dividiu suas musicas em pastas com o nome dos autores , bandas ou CDs, bastara digitar o nome de um destes itens e ele listará todos os arquivos contendo a palavra digitada. Exemplo: Escrevendo Jobim, ele encontraria todas as suas musicas do Tom Jobim, caso voce tivesse criado uma pasta chamada Jobim. Se a palavra digitada estiver no nome do arquivo, tambem encontrara a palavra. Exemplo: Digitando Samba, ele poderia encontrar Samba e Amor.cfc, Samba de Uma Nota So.cfc e assim em diante. No item Tipo de Documento a Pesquisar, servira para voce definir se quer procurar arquivos nos formatos .cfc feito no editor cavaquinho ou Violao,Viola, Teclado ou um arquivo no formato preview .prv que voce salvou. Pode ser um songbook salvo, por exemplo.

Clicando no botão Pesquisar ou Tecla F2, o cifracil fara a pesquisa e mostrara o resultado no quadro Arquivos Encontrados. Então basta clicar com o mouse na caixinha do lado esquerdo do arquivo e clicar no botão Abrir Arquivo ou F3 e o arquivo escolhido sera aberto.


Editor do Cifracil

O Editor do Cifracil é a sua principal ferramenta de trabalho. É nele que você criará documentos no Cifrácil. Vejamos como ele é composto:

Na figura acima, vemos duas Abas, com os títulos Editor e E A D G B E (Esta última aba é denominada como Repositório de Acordes do Documento), respectivamente. Na aba Editor, como o próprio nome diz, vemos a área em branco, onde digitaremos a música que representará o documento. É nela que escreveremos a música cifrada. Ainda na Aba Editor vemos uma barra de ferramentas do editor, vejamos para que serve para cada botão.

A maioria dos botões do editor tem uma Tecla de Atalho. Ou seja, em vez de clicar o botão você poderá teclar a tecla de atalho do botão que executará o botão sem precisar clica-lo com o mouse.

Tecla de Atalho: F2

Salvar o documento aberto no editor. Quando você salva o documento, este botão fica com uma coloração cinza. O botão só volta ao normal quando é feita alguma modificação qualquer no documento, indicando então, que o documento está pendente de alteração. Quando o seu documento é novo, um dialogo vai ser mostrado para você preencher o nome do documento a ser salvo. Coloque um nome para o documento e ele será salvo com a extensão .cfc (extensão do Cifracil Cavaquinho, indica que este documento é um documento do Cifracil). Sé o documento já foi salvo uma vez, o diálogo para dar nome ao arquivo é desnecessário, por isto ele simplesmente salva o documento sem perguntar o nome do mesmo.

Se você desejar salvar o documento com outro nome, preservando o documento atual, você deverá utilizar a opção Salvar Como. (clique no menu do sistema em Documento e escolha a opção Salvar Como.) Pode ser que você queira fazer isto na seguinte situação: Tenho um documento no Cifracil que está em uma determinada tonalidade. Quero manter dois documentos, um numa tonalidade e outro na outra. Pois bem, utilizo o botão da barra do editor que faz transposição e então, em seguido mando salvar o documento como outro nome, ficando assim com duas versões do documento.

Tecla de Atalho: F3

O botão de Visualizar impressão, serve para montar um preview do documento (visualização de Impressão) que será impresso. Ele junta o conteúdo das duas Abas (Editor e Repositório dos Acordes (D G B D)

em um documento só. O seu documento vira uma pagina de um songbook. A partir da sua página de preview montada, será possível imprimi-la em sua impressora. Para maiores esclarecimentos clique no tópico Preview do Documento

Cabe ainda esclarecer que antes de montar o preview do documento, um diálogo é mostrado para você, como você pode ver na figura abaixo:

A pagina do Preview poderá ser montada em dois estilos: Não Colunar e Colunar.

O Estilo Colunar divide a folha do preview em duas colunas. Embora não apareça uma linha de coluna separando o texto, esta coluna existe. Como é montado o tamanho da primeira e da segunda coluna ? O Cifracil corre toda a pagina e encontra a linha de maior tamanho. A divisão entre as colunas será baseada nesta linha. Portanto se você deseja ver o texto da sua Cifra em colunas, não faça linhas muito compridas no seu texto, pois você corre o risto do Cifracil calcular a primeira coluna muito larga, deixando um espaço pequeno para a segunda coluna, podendo o conteudo desta sair da pagina. A visualização do texto colunar fica interessante quando você tem uma música que tenha uma letra grande. Neste caso a impressão colunar fará com que sua pagina tenha letra na primeira coluna e na segunda. Neste tipo de impressão o Cifracil vai preenchendo a pagina na primeira coluna. Se acaba o texto ele começa a por os acordes, se não ele continua pondo o texto da cifra e quando chega no fim da pagina, o software começa a preencher a segunda coluna desta pagina, seja com o restante do texto ou com os acordes, caso a primeira coluna ter terminado o texto ainda nela. Repetimos mais uma vez, se você visualizar o preview e ver que a segunda coluna ficou apertada, e sobrou texto para fora da pagina, basta procurar a maior linha e quebra-la, desta forma o software estará recalculando a posição das colunas novamente e seu texto será melhor dividido entre estas duas colunas.

A impressão não colunar, não se importa em fazer colunas na pagina. O texto vai sendo colocado na pagina, se ele não couber na pagina, ele não será jogado para outra coluna e sim pra próxima pagina. No lado direito da folha os acordes vão sendo colocados, para aproveitar o espaço vazio desta parte da pagina. O posicionamento dos acordes no lado direito também é calculado baseado na maior linha da pagina. Se você quer que caiba mais acordes na porção direita da pagina diminua a maior linha quebrando-a pra próxima pagina e o problema está resolvido. Na última pagina, o software procura colocar mais acordes na parte que sobrou da folha, embaixo do final do texto cifrado. Nos dois tipos de preview, quando o texto da cifra está diposto nas paginas, assim que os acordes preencherem o resto da ultima folha que contém texto cifrado, novas paginas serão criadas para colocar o restante dos acordes da música.

Experimente visualizar um mesmo texto com as duas opções mostradas acima. Sempre ao escolher uma das opções você deve clicar no botão OK. Ou se não deseja ver o preview de impressão clique no botão Cancelar. Você também poderá escolher o conteúdo a ser impresso na página, poderá marcar o desmarcar a caixinha que indica se a afinação será mostrada no documento e também poderá escolher uma das configurações do braço cadastradas.

A caixinha Começa com as Digitações, se marcada fará com que as digitações, os desenhos dos acordes, sejam colocados na folha de preview logo abaixo da linha Autor da música. Fica bastante interessante utilizar esta opção.

Criamos um botão com o desenho de um disquete. Este botão serve para salvar as opções que costuma configurar nesta janela. Assim você salva a configuração que mais utiliza e toda vez que esta tela é chamada estas opções são preenchidas automaticamente. Isto agiliza bem sua vida.

É possível que você não esteja com cartucho de tinta colorida ou não tenha uma impressora que imprime colorido. Para facilitar sua vida você poderá informar na Caixinho Cores da Página a opão Preto e Branco, e então sua pagina de preview será montada sem utilizar cores. Se quer ver a pagina com os acordes pintados em cores diferentes e tudo o mais escolha a opção Colorida.

Criamos um recurso muito interessante que é a possibilidade de você, em vez de gerar um preview da pagina do documento, possa gerar um documento no formato PDF. É um formato muito conhecido atualmente. Para ler arquivos deste tipo você deverá baixar da internet o programa Acrobat Reader, que é freeware, ou seja, não precisa comprar, é de graça. Poderá baixa-lo no link http://www.adobe.com/products/acrobat/readstep2.html

Embora ja estejamos na versão 5, as versões 3 ou 4 são menores e abrem da mesma forma o pdf. Então, como diziamos, para gerar o arquivo no formato pdf, basta clicar na opção Exportar PDF e então, quando você clicar no botão Ok o Cifracil irá solicitar o nome do arquivo a ser criado. Coloque o nome sem extensão e poderá navegar na caixa de dialogo que salva o arquivo até a pasta desejada, para salvar o documento onde preferir. Após clicar no botão Salvar o cifracil começará a exportação e uma janela será mostrada. Quando aparecer um botão escrito Fechar, note que o nome do arquivo salvo será mostrado e voce poderá fechar a tela e abrir o seu pdf no Acrobat Reader.

Também poderá gerar PDF's de seus songbooks. Veja como gerar um pdf de um songbook no item Cadastro de Songbook

Gostariamos de esclarecer que nesta versão, quando voce configura na palheta de estilos algum fonte com a caracteristica de negrito, somente os fontes Times New Roman ou Helvetica é que conseguimos coloca-los como negrito no documento PDF.

Mas temos uma solução para resolver este problema. Caso voce tenha configurado um fonte como Arial por exemplo, poderá configurar a palheta de estilos para utilizar na linha cifra por exemplo, Arial Black. Ou seja, qualquer fonte que ja tiver o negrito imbutido funcionará bem.

Tecla de Atalho:F4

Este botão chama a Palheta de Estilos do seu editor.

Tecla de Atalho:F5

Este botão aplica os estilos configurados na Palheta de estilos em todo o texto. Este botão também está dentro da tela Palheta de Estilos do Editor, esplicado logo acima.

Tecla de Atalho: F6

Este botão é que irá interpretar o texto digitado no Cifracil. Ao clicar nele, o Cifracil irá percorrer todo o texto digitado, linha por linha, procurando identificar cada acorde mencionado em seu texto. Para cada acorde encontrado no texto o Cifracil procurará a digitação default deste acorde no dicionário de acordes e o colocará desenhado na aba Repositório de Acordes do Documento (aba localizada ao lado a aba Editor).

Para que o Cifracil consiga interpretar corretamente o texto digitado existem regras que devem ser seguidas. Como já afirmamos acima, no momento em que o Cifracil está interpretando o texto, cada linha do texto vai sendo lida. A primeira coisa que o Cifracil faz é identificar se a linha que esta sendo lida é uma linha que contém os acordes da música ou é uma linha que contém texto, provavelmente a letra da música. Ou seja, ele identifica os elementos básicos do texto. No momento da interpretação ele está apenas preocupado em achar os acordes da música. Para que o Cifracil entenda que a linha que está sendo interpretada trata-se de uma linha que contenha os acordes da música, devemos colocar nela apenas acordes válidos. Como não existe uma padronização mundial nas regras utilizadas para dar nomes aos acordes tivemos que adotar uma padronização de nomeclatora, caso contrário, ficaria muito difícil para o software entender corretamente a estrutura do acorde, seus intervalos. Procuramos adotar uma nomeclatura mais próxima possível das obras do famoso autor brasileiro Almir Chediak, autor do livro Dicionario de Acordes Cifrados. Para melhor compreender as regras de interpretação do texto em cifra clique aqui: Regras para reconhecer acordes no texto . Os acorde só serão reconhecidos no Cifrácil se seguirem estas regras.É importante que você não misture símbolos desconhecidos, letra de música, na mesma linha em que estiver digitando o nome dos acordes. Ex: La la la C F G. O Cifrácil tem a seguinte filosofia: Uma linha que tenha qualquer carácter não utilizado para dar nome a um acorde, não é reconhecida como uma linha de acordes. A não ser que você utilize um recurso do Cifracil chamado Comentário. Digamos que você deseja colocar no início da música uma introdução. Só que você quer escrever a palavra introdução na mesma linha em que colocará alguns acordes. Utilize colchetes e o Cifracil despresará seu comentário interpretando a linha como linha de acordes e não como uma linha texto.

Ex: [Introdução] C F G C F G

Você pode escrever qualquer coisa numa linha de acordes, desde que coloque colchetes no inicio e fim do seu comentário. Use e abuse deste exelente recurso !

Observação importante: Este botão deve ser sempre utilizado quando você acabou de escrever ou copiar de outro editor de textos uma música cifrada, afinal é através dele que o Cifracil encontrará os acordes da sua música e o desenhará na aba Repositório de Acordes do Documento. Imagine também que você ja utilizou este botão uma vez, porém resolveu mexer na cifragem da sua música. Se você inseriu ou retirou algum acorde do texto, o documento do Cifracil deve ser novamente interpretado para que os acordes inseridos sejam colocados na aba Repositório de Acordes do Documento ou apagados de lá, caso você os tenha retirado do seu texto.

Ao final da interpretação do texto o Cifracil Aplica o Estilo em seu texto, para deixa-lo formatado.

Tecla de Atalho:Ctrl+F

Basta preencher a palavra que se deseja pesquisar na caixinha Localizar e clicar no botão Localizar Próximo. O prográma irá parar na primeira ocorrência do palavra pesquisada. Se quiser continuar procurando basta clicar novamente no botão Localizar Próximo.

Além de pesquisar ele será muito útil para trocar expressões do texto. Se você quiser trocar um texto qualquer do seu texto preencha as caixinhas Localizar (com o texto que você esta procurando para ser trocado e Substituir pelo texto que você quer substituir, e em seguida clique no botão Substituir Texto. Se você tiver clicado em Substituir Todas então todo o texto será trocado, se não ele irá trocando a cada ocorrência do texto encontrada.

Temos dois botões muito importantes nesta caixa de dialogo: Tabela Padroes Cifra e Substituição Texto por Padrões

Vamos começar a falar do botão com o título Tabela Padrões Cifra. No item do help denominado Regras para reconhecer acordes no texto , vimos que o Cifracil adota um padrão de nomeclatura para reconhecer os acordes digitados nos textos cifrados. Para facilitar a sua vida, criamos uma tabela que será utilizada para trocar ocorrências no texto que o Cifracil desconhece por símbolos que o cifracil reconhece. Por exemplo: C7+, a sétima maior para o Cifracil é reconhecido como 7M e não 7+. Cadastramos esta conversão na Tabela de Padrões de Cifra do Cifracil. O acesso a esta tabela é feito ao clicar este botão Tabela Padrões Cifra. A seguinte tela aparecerá:

Como você pode ver, na figura acima, nós já cadastramos varios padrões para poupa-lo. Acreditamos que os padrões que já cadastramos seja suficiente para a maioria dos textos cifrados que você precisará converter, utilizando esta tabela. Mesmo assim, se você precisar, poderá cadastrar novos padrões. Basta clicar no primeiro botão da barra de navegação, que funciona de forma semelhante a utilizada no cadastramento de afinações, para que uma nova linha seja aberta na grade. Preencha o campo Procurar por com o texto que será procurado pelo Cifracil para ser substituido pelo conteúdo do campo Trocar para. Estas substituições só serão realizadas quando você clicar no botão Substituição Texto por Padrões , localizado ao lado do botão Tela Padrões Cifra. Ao preencher estes dois campos clique no terceiro botão (uma mão escrevendo com um lapis) para gravar o novo padrão. Para excluir o padrão basta clicar no quarto botão( desenho do lapis com uma borracha). O segundo botão (uma mão escrevendo em uma folha) será utilizado apenas para você poder modificar algum padrão. Também colocamos uma pequena pesquisa, uma forma de localizarmos padrões, na tabela. Afinal de contas, ela vai crescendo e para que você não tenha dificuldades em encontrar os padrões cadastrados colocamos uma pesquisa pelos dois campos da tabela: Procurar Por e Trocar Para. Escolha qual dos dois você quer pesquisar, clicando nas opões do quadrinho Localizar Texto no campo. e em seguida digite o texto que quer pesquisar. Após digitar o texto a pesquisar no campo de edição, abaixo da quadrinho Localizar Texto no campo, clique no botão ao lado para localizar o texto.

Para fixarmos o aprendizado explicaremos que ao clicarmos no botão Substituição Texto por Padrões , o software estará procurando por cada ocorrência do campo Procurar Por da tabela de Padrões Cifra, vista na figura acima, trocando seu conteúdo pelo respectivo texto cadastrado no campo Trocar para, resultando no seu texto convertido e formatado no padrão do Cifracil.

Nós resolvemos extender um pouco mais a funcionalidade da substituição do texto baseado na tabela de padrões, para trocar não apenas o texto em função da interpretação da cifra, mas também em função de montar um padrão estético da Cifra. Por exemplo: Como você pode ver na figura acima, colocamos o padrão de troca 7/6 para 7(6). Embora o Cifracil interprete os dois padrões sem problema algum, resolvemos cadastrar este padrão para termos uma cifra esteticamente mais bonita. Desta forma a tabela de Padrões de Cifra, também está sendo utilizada não apenas para converter padrões de cifragem desconhecidas pelo Cifracil, mas também para melhorar o layout da cifragem do texto a ser convertido.

Tecla de Atalho:F7

É o mesmo botão Substituição Texto por Padrões, já explicado logo acima. Apenas trouxemos ele para a barra do editor para facilitar o acesso a esta função.

Tecla de Atalho:Ctrl+F7

É o mesmo botão Tabela Padrôes Cifra, ja explicado logo acima. Apenas trouxemos ele para a barra do editor para facilitar o acesso a esta função.

Tecla de Atalho:F8

Utilize este botão quando você quer transpor uma música para uma tonalidade diferente da utilizada no seu documento corrente. Ao clicar este botão, será mostrado uma caixa de dialogo, como você pode ver abaixo:

Na caixinha Direção Semitons, você deve escolher com o mouse se você vai transpor seus acordes do seu documento aumentando ou diminuindo os acordes do seu documento em um número de semitons escolhidos por você (utilize o mouse nas setinhas abaixo da palavra Semitons) . Ao clicar o botão OK o Cifrácil irá trocar no texto todos os acordes para os novos acordes transpostos. Imagine por exemplo que você tem uma música com uma sequência de acordes assim: Dm7 G7 C7M. Se você quiser subir seu documento em 1 tom = (2 semitons) então marque Subir 2 semitons e clique em OK. O Cifracil irá trocar sua sequência para: Em7 A7 D7M. É importante saber que o Cifracil troca no texto todos os acordes encontrados e interpreta-o novamente. Isto fará com que a lista de acordes seja trocada, e a digitação escolhida para cada novo acorde transposto será a digitação definida como default no dicionário de acordes . Portanto, verifique após a transposição as digitações colocadas na aba Repositório de Acordes e realize a troca de digitações que você achar necessário ao seu documento. Afinal você pode estar utilizando alguma digitação diferente das definidas como default para cada acorde. O Cifracil só fará a transposição se todos os acordes novos forem encontrados no dicionário, caso contrario será mostrada uma janela mostrando os acordes que o programa não achou ao tentar fazer a transposição. Embora isto seja possível acontecer, é pouco provavel, pois temos uma grande quantidade de acordes cadastrados no nosso dicionário de acordes.

Tecla de Atalho:Ctrl+X

Este botão será utilizado para recortar um pedaço do texto do seu documento no Cifracil, pode ser todo o documento, para posteriormente cola-lo no próprio editor do Cifrácil ou em outro qualquer que estiver aberto. O texto recortado vai para área de transferência do Windows, para que você possa cola-lo novamente. Você também poderá realizar a mesma tarefa deste botão utilizando as teclas de atalho Ctrl + X. (Basta pressionar a tecla Control e a tecla X no texto selecionado)

Tecla de Atalho:Ctrl+C

Este botão servirá para você copiar um texto selecionado no Cifracil para área de transferência do Windows. Posteriormente você poderá cola-lo em um outro editor de textos qualquer ou no próprio Cifracil, em outro trecho do seu texto. Também poderá realizar esta mesma tarefa utilizando as teclas de atalho Ctrl + C (Basta pressionar a tecla control e a tecla C no texto selecionado)

Tecla de Atalho:Ctrl+V

Este botão servirá para você colar um texto que estiver na área de transferência do Windows no editor do Cifrácil. Será muito útil para você importar um texto que você tem, vindo de outro editor.

Veja este assunto no tópico Importando uma Música para o Cifrácil. Pode ser também que o texto a ser colado seja um trecho da própria musica que você esta editando, e você queira repeti-lo mais adiante em seu texto. Para fazer isto, basta marcar o texto com o mouse e copia-lo para a área de transferência do Windows. Feito isto, escolha o local que você quer colar o texto, clicando com o mouse neste local e então utilize este botão para colar o texto.

Utilize este botão para desfazer a última ação realizada no seu editor de textos. Imagine que você colou algo no seu texto ou acabou de digitar uma palavra que não deveria e você quer voltar atrás, ter o texto na situação que estava antes. Utilize este botão e o texto voltará ao estado em que estava, antes de realizar a ação indesejada.

Este botão será útil quando você importar textos com tabulações vinda de outros editores. Imagine que você importou uma música que você cifrou no Word. Se você utilizou tabulação neste texto importado, é melhor você retirar os controles de tabulação embutidos no texto. Porque ? Porque o Cifracil não saberá tratar o caracter de tabulação, vindo do Word e quando montar o Preview do seu documento aparecerão uns quadradinhos no seu texto. Para evita-los você deverá tira-los, utilizando este botão. Para tabular o texto novamente utilize espaços em branco ou utilize o botão de tabulação do Cifracil, mostrado logo abaixo. Dica: Quando você importa um texto utilizando o botão de importação, o Cifracil já faz a retirada da tabulação do documento importado, não precisando utilizar este botão após a importação.

Tecla de Atalho:F9

Este botão faz o papel da tabulação no Cifracil. Na verdade ele coloca alguns espaços em branco na frente do cursor no editor de textos do Cifracil.

Tecla de Atalho:F10

Este botão serve para colocar o sinal diminuto em um acorde. Imagine, por exemplo, que você quer colocar no texto o acorde Si Diminuto. Escreva B e clique neste botão. O resultado será: B°. Se você preferir colocar Bdim o editor também entendera dim como Diminuto.

Tecla de Atalho:F11

Este botão será de muita utilidade quando você abre um documento do Cifracil que você baixou da Internet ou recebeu de algum amigo. Através deste botão, o Cifracil verifica se as digitações dos acordes utilizadas neste documento estão cadastrados no dicionario do Cifracil. Caso alguma digitação ainda não esteja cadastrada no Cifracil, você será notificado e o Software perguntará se você deseja inclui-la no seu dicionário. Caso positivo, a digitação em questão será incluida no dicionário do Cifracil.

Tecla de Atalho:F12

Este botão servirá para importar documentos cifrados em outros formatos. O Cifracil pode importar musicas cifradas no formato .DOC (Ms Word), Texto (.TXT) , Rich Edit (.RTF) ou Cifracil para Teclado (.CFT) (Quando voce importa um documento Cifracil Teclado (.cft) o cifracil aproveita

o texto cifrado e interpreta novamente o documento, utilizando então as digitações default de cada acorde que aparece na cifra)

. Ao importar um arquivo em um destes formatos, o Cifracil fará o seguinte com o texto importado:

1) Retirará o Tab (no caso de ter utilizado a tecla de tabulação Tab do editor);

2) Converterá a Cifra, trocando o nome dos acordes utilizados para o padrão de interpretação de acordes do Cifracil, utilizando a Tabela de Padrões de Cifra, cadastrada no Cifrácil. (veja no texto acima, quando falamos do botão de pesquisa no texto (o botão do binóculo), lá você encontrará explicações sobre a nossa conversão do Texto cifrado através da Tabela de Padrões de Cifras do Cifracil ).

3) Aplica no texto a formatação dada na Palheta de Estilos do editor.

4) Interpreta os acordes do texto, localizando-os no dicionário de acordes.

Lembre-se que este botão só fica visível para documentos novos. Afinal quando você vai importar um documento, você terá que criar um documento novo e então chamará este botão para importar o documento.

Tecla de Atalho: Ctrl+E

Este botão servirá para exportar um documento do cifracil. Embora nos esforcemos bastante para dar aos documentos do cifracil uma aparência agradavel, é possivel que você queira trabalhar com a musica cifrada no Cifracil de uma forma mais livre. Digamos por exemplo, que eu esteja fazendo um livro ou uma revista. Para dar mais liberdade na edição deste livro ou revista criamos esta opção de exportação. Ao clicar neste botão o Cifracil apresentará o a seguinte tela para você configurar sua exportação:

Nesta tela você poderá escolher o que irá exportar clicando em uma das opções da caixinha Conteúdo a Exportar. Poderá exportar somente o texto cifrado que está no editor, apenas as digitações que estão desenhadas na aba do Repositório de Acordes do documento, ou então os dois. Se você tiver escolhido exportar o texto cifrado, o Cifracil solicitará um diretorio e um nome a ser dado para o texto a ser exportado no formato Rich Edit (.rtf), que pode ser importado facilmente no Ms Word. Se tiver escolhido esportar as digitações dos acordes aparecerá uma janelinha para você marcar qual formato de arquivo serão salvos as digitações do seu documento. O Cifracil permitirá salva-los em Bitmaps (.bmp), JPeg (.jpg, muito utilizado na internet) e dois tipos de Metafile : emf e wmf. As digitações serão salvas no mesmo diretório escolhido para a exportação do texto, caso tenha escolhido exporta-lo, ou então, se não tiver escolhido exportar o texto, o Cifracil solicitará para você o diretório para exportação das digitações. Exportando desta forma você poderá importar todos estes elementos para editores como o Page Maker, por exemplo e poderá fazer uma formatação mais livre do documento cifrado, posicionando texto e acordes como você bem entender.

Também colocamos este mesmo botão dentro da pagina de preview, só que lá ele tem um comportamento um pouco diferente. La dentro, ao clicar neste botão, a pagina corrente do preview será exportada inteira no formato EMF (Metafile)

Exportar seu arquivo para HTML

Também poderá Exportar seu documento .cfc para o formato Html. Basta marcar com o mouse a opção Exportar Html e o cifracil solicitará o nome do seu arquivo html e após clicar no botão salvar deverá escolher o formato das digitações. Escolha esportar os acordes para jpeg ou bitmap (pois estes dois formatos de imagem são utilizados na internet, o mais utilizado seria o jpeg.). Você verá que o cifracil gerará um arquivo html e varios arquivos .jpegs ou .bimaps que contem os acordes. Entre no explorer e dê um duplo clique no arquivo hml criado. Seu browser será aberto e poderá ver a misica cifrada nele. Este recurso é exelente para quem publica paginas de musica cifrada na internet.

Informamos que nesta versão não é possivel ainda fazermos um documento html no formato Colunar, utilizado no preview. Mas mesmo assim acreditamos que o html gerado tenha ficado muito bom.

Tecla de Atalho: Ctrl + R

Ordena as Digitações do documento na Aba do Repósitório de Acordes na ordem em que eles aparecem no texto. Muitos preferem ordenar os acordes nesta ordem, em vez de ve-los em ordem alfabética. Vale anotar que, você deve utilizar esta opção após estar com o documento pronto, isto é, depois de ter interpretado todos os acordes. Se precisar mexer em um documento para acrescentar ou apagar acordes no texto, e quiser manter esta ordenação, clique neste botão novamente para que os acordes fiquem ordenados corretamente.

Tecla de Atalho: Ctrl + J

Quando abrimos mais de uma janela ao mesmo tempo, e em seguida resolvemos fecha-las, acontece um pequeno inconveniente na tela do editor: O editor diminui o tamanho da janela do texto, ficando menor que o espaço da tela pode comportar. Basta mandar redesenhar a tela com este botão e ela passa para o tamanho normal, isto é, ocupando toda área livre para a janela do editor.

Este botão nos permite salvar o arquivo aberto no editor no formato MsWord. Ao clicar neste botao sera aberto uma janela onde voce podera escolher o nome do arquivo e a pasta onde salva-lo. Atenção ! Até a presente versao, ao salvar o documento cifracil para o MsWord, os desenhos dos acordes foram colocados no final do texto cifracil, um embaixo do outro, sendo que não foi possivel colocar os acordes desenhados lado a lado. Por isto, ao salvar o documento como MsWord, voce tera que arrastar os acordes com o mouse e posiciona-los um ao lado do outro, para que que seu documento fique com um layout mais agradavel. Mesmo assim, ja consideramos um ganho a utilzação deste recurso.

Vejamos agora a Aba denominada Repositório de Acordes do Documento, como mostra na figura abaixo:

Nesta aba serão mostrados as digitaçóes dos acordes encontrados na música. Assim, pelo desenho dos acordes poderemos toca-la com muito mais facilidade. O Título da aba poderá variar, dependendo da afinação escolhida para o documento que está sendo redigido. O Cifracil permite você fazer documentos com diferentes afinações do cavaquinho. A Afinação mais usual para o cavaquinho é afinar da 4.Corda para a primeira corda utilizando as notas D G B D, mas é possível escrever uma música utilizando uma afinação diferente no instrumento. No songbook do Djavan, editado pelo Almir Chediak, por exemplo, encontramos algumas música sendo tocadas com a 6.corda afinada em Ré.

Como você vê na figura acima, há uma lista na esquerda com vários nomes de acordes. Estes acordes são os acordes encontrado em todo o documento, após este ter sido interpretado. Se eu colocar ou retirar do texto algum acorde que está nesta lista, então deverei clicar no botão de Interpretação do texto, já explicado acima, para que esta lista seja atualizada. No caso de um acorde novo, ele entrará na lista. Se você o retirou do texto, ele desaparecerá.

Com cada acorde da lista eu poderei realizar algumas ações. Basta que eu, antes de tudo, clique com o mouse no acorde selecionando-o, dessa forma, no Cifracil. A partir daí eu poderei:

1) Modificar a digitação do acorde selecionado. Lembremos que quando o texto for interpretado pela primeira vez, o Cifracil pega a digitação defalt de cada acorde. Poderemos trocar a digitação se a digitação mostrada a direita da lista (onde vemos o desenho de cada acorde) não for a que a gente quer utilizar no documento. Por exemplo: Digamos que no nosso documento temos a digitação do acorde de Do maior. Digamos que esta digitação seja aquela clássica em que o Mi maior é feito na primeira casa. Se quisermos o Mi Maior na quarta casa então basta clicarmos no botão acima da lista com o título Mudar Digitação Acorde Selecionado. Uma tela será mostrada com todas as digitações cadastradas para o acorde selecionado. Escolha a digitação que você quer utilizar no documento clicando com o mouse em cima dela. A digitação escolhida ficará com a cor amarelada. Clique no botão OK e a digitação escolhida, no nosso exemplo o Dó com pestana na terceira casa, e este será trocado no nosso documento.

2) Definir se o acorde selecionado será incluido no Preview

Veja na lista de acordes uma caixinha no lado esquerdo do nome de cada acorde. Se esta caixinha estiver marcada, então o acorde selecionado será desenhado no preview do documento , caso contrário, ele não será desenhado no preview do documento. É possível que você não queira ocupar espaço no seu documento mostrando digitações simples, que você já está acostumado a fazer. Neste caso você pode desmarcar esta opção.

3) Ordenar Digitações

Clique no botão Ordena Digitação, para que todas as digitações mostradas nesta aba apareçam em ordem alfabética (da esquerda para direita e de cima para baixo). Para uma música que tenha muitos acordes, será mais fácil localizar os as digitações de cada acorde.

Uma observação interessante a fazer é que se o seu documento tiver muitas digitações a serem mostradas nesta aba, uma barra de rolagem será mostrada a direita das digitações para você poder rolar a tela para cima e para baixo, fazendo com que você possa ver todas as digitações utilizadas no documento.

4) Ouvir o acorde na placa de som do meu micro

Ao dar um leve clique no acorde que está na lista basta clicar com o botão direito do mouse e se você tiver placa de som instalada e configurada corretamente no seu micro, ouvirá o som do acorde.


Palheta de Estilos

A Palheta de Estilos é utilizada para formatar o seu texto, sua música cifrada. Servirá para dar uma aparência personalizada a sua música cifrada.A palheta de Estilos age sobre os quatro elementos básicos que compõe o texto no cifracil:

Para cada elemento do texto você definirá sua aparência. Ou seja, cada elemento possui as propriedades fonte, tamaho, cor, efeitos de Negrido, Italico, Sublinhado e Alinhamento (Apenas para Título e Autor). que podem ser configuradas por você.

Para configurar cada elemento básico (Título,Autor,Cifra e Corpo Texto) você deverá clicar com o mouse em uma das opções da caixinha "Estilo Aplicado em". Ou seja, quando quiser configurar a aparência da Cifra, por exemplo, clique dentro do circulo onde está escrito Cifra. Todas as configurações referentes ao elemento Cifra serão mostrados imediatamente. Experimente clicar em cada opção (Titulo, Autor,etc) e veja por exemplo, que o nome da fonte muda ou tamanho podem estar diferentes. E note também que um texto é mostrado, com o nome da opção que você está configurando, tendo em sí as características configuradas. Isto serve para você ter uma ideia da aparência que o elemento configurado irá assumir. Pois bem, para cada estilo escolha o fonte utilizado na caixa de listagem de fontes, defina o tamaho do fonte clicando nas setas para baixo ou para cima, se quiser algum efeito de negrito, italico, sublinhado clique nos botões B, I ou U. Para modificar a cor clique no botão com as letras A,B e C e um dialogo será apresentado para escolher as cores. Os botões de Alinhamento a Esquerda, Centralizado ou Direita só poderão ser utilizados para os elementos Título e Autor.

Importante: A pagina de preeview do seu documento é montada baseada na palheta de estilos. Ou seja, se na palheta estiver definido que o corpo texto será Times New Roman, tamanho 12, cor Preto, assím sairá no seu preeview. Por isto, se você importar um texto já formatado vindo de outro editor é imprecindivel que você o formate no Cifracil da maneira que melhor lhe pareça, para que o texto do editor reflita as caracteristicas desejadas do texto. Caso contrário, o texto importado estará numa formatação e sua palheta pode estar com outra. O que acontecerá é que seu texto importado estará com uma aparência e quando você der o preeview, seu texto aparecerá, com as características configuradas na palheta.

Vejamos agora para que servem os últimos quatro botões, localizados a direita da palheta.

Este botão é útil quando queremos capturar as propriedades de um texto que colamos no nosso editor, vindo de um editor de textos como o Word, por exemplo. Digamos que temos uma música cifrada no Ms Word e transferimos o texto através da área de transferência para o Cifracil. É muito provável que este texto esteja formatado de forma diretente das configurações da sua Palheta de Estilo. Se quisermos que a página de preeveiw seja montada com a mesma formatação do documento transferido do Ms Word para o Cifracil, então teremos que configurar a Palheta de Estilos com a aparência do texto copiado. Para facilitar esta tarefa podemos utilizar este botão para configurar cada elemento do texto, copiando as propriedades da linha onde seu cursor está posicionado para a palheta de estilos. Basta escolher o elemento do texto para onde estamos querendo copiar o estilo e clicar neste botão. Se você tiver escolhido o elemento Corpo Texto, por exemplo, você deve clicar com o mouse em cima de uma linha qualquer, que contenha a letra da música e então ao clicar este botão você terá configurado sua palheta com o fonte, tamanho e cor do texto onde está o seu cursor.

Cada documento quando é salvo no Cifracil, guarda a Palheta de Estilos utilizada nele. Imagine que você receba de um amigo um documento feito no cifrácil. O documento dele pode estar utilizando, muito provavelmente, uma configuração da palheta de estilos diferente da que você costuma usar. Se você quiser aplicar o estilo definido pela sua palheta de estilos no documento recebido de seu amigo basta clicar neste botão e a palheta de estilos será carregada com sua configuração. Esta será aplicada ao documento de seu amigo, que você abriu no Cifracil. Sendo assim, com este botão, você aplica a um documento qualquer, que tenha um estilo diferente do seu, a sua propria configuração da palheta de estilos.

Este botão é utilizado para salvar o estilo que você tiver configurado na sua palheta. Este será o estilo default. Ou seja, para um novo documento, a Palheta de Estilos do Cifracil será automaticamente configurada com a Palheta de Estilos que você gravou pela última vez ao acionar este botão em sua palheta de estilos. Quando você abre um documento qualquer feito no Cifracil, a Palheta de Estilos assumirá as configurações utilizadas por este documento. Ou seja, cada documento feito no Cifracil tem informações da palheta que foi utilizada na sua construção. Então, se um José e uma Maria fazem um documento no Cifracil, cada documento poderá ter utilizado uma Palheta de Estilos diferente para o documento criado. Quando cada um salvar o seu documento no Cifracil, será guardado tando no documento do João quanto no da Maria a Palheta de Estilos que cada um utilizou em seu respectivo documento.

Este é o principal botão da Palheta de Estilos. É ele que deve ser utilizado para aplicar ao texto do seu documento no Cifracil todas as propriedades dos elementos básicos do texto (Título, Autor, Cifra e Corpo Texto) que você configurou na palheta. Quando você tiver digitado uma nova música cifrada no Cifracil, utilize este botão para dar a formatação no seu texto. Esta formatação será a que você configurou como formatação default para todos os seus textos. Quando você abrir um documento com uma aparencia diferente da que você configurou na palheta para utilizar em todos os seus documentos, também poderá utilizar este botão para colocar a sua formatação no documento que você abriu. Pode ser também que você tenha resolvido modificar algum elemento básico do texto e você quer aplicar a um documento seu qualquer. Vamos supor que o elemento do texto Cifra estava configurado na palheta com a cor azul e agora você quer ver a cifra de vermelho. Basta modificar a palheta e mandar aplicar a nova cor ao texto através deste botão.


digitação

Digitação de um acorde é o forma física como colocamos os dedos no braço do instrumento para fazermos um acorde. Um acorde possui varias digitações, ou seja, formas diferentes de tocar um mesmo acorde, em varias regiões do intrumento.


Barra de Ferramentas

A barra de ferramentas possui botões para realizar tarefas muito utilizadas no software, podendo encurtar seu caminho, pois ela evita que você tenha que acessar suas funções pelo menu do sistema. Para cada botão da barra de ferramentas existe uma opção correspondente no menu do sistema.

O primeiro botão deve ser utilizado para criar um novo documento no Cifrácil.

O segundo botão serve para abrir um documento previamente criado pelo Cifracil.

O terceiro botão permitira voce localizar algum arquivo do cifracil que deseja abrir.

Para mais detalhes veja o topico Pesquisa de Arquivos

O quarto botão serve para acessar o dicionário de acordes .

O quinto botão serve trocar o dicionário aberto ara outro dicionário de outra afinação.

O sexto botão serve para abrir a tela de cadastramento de songbooks, onde poderá criar um songbook no cifracil.

O setimo botão serve para abrir no cifrácil arquivos no formato songbook .sbn

O oitavo botão serve para chamar o diálogo de impressão do Windows, assim você poderá modificar configuração da sua impressora.

Os três últimos botões serão úteis quando você estiver com várias janelas abertas no cifracil e você deseja organiza-las na tela. Repare como as janelas ficarão através dos desenhos mostrados nos botões.


Regras para reconhecer acordes no texto

Como já afirmamos, ao explicar a funcionalidade do botão de interpretação de textos do , Editor do Cifracil , não existe uma padronização mundial para dar nomes aos acordes nos textos cifrados. Para que o Cifracil consiga interpretar o texto, identificar um acorde, tivemos que adotar uma padronzação. São essas as regras que estamos explicando neste tópico. Procuramos adotar uma nomeclatura mais próxima possível das obras do famoso autor brasileiro Almir Chediak, autor do livro Dicionario de Acordes Cifrados. Vamos as Regras:

1) O acorde deve começar com uma letra maiúscula de A-G (La,Si,...Sol). Logo em seguida podemos ter opcionalmente os símbolos # ou b (sustenido ou bemol).

Ex: A# B Db

Tome cuidado ao utilizar os simbolos # ou b logo depois da Fundamental, visto que eles também podem estar sendo utilizados em intervalos como #4, por exemplo. Veja este caso:

Se você escrever C#4, o cifracil terá de saber se o sustenido pertence ao intervalo, neste caso de quarta aumentada #4, ou se você quis dizer que o sustenido é da fundamental (Tônica), neste caso seria Dó#. Utilize o parêntese para separar o intervalo da Fundamental. Neste caso você poderia utiliza-lo de duas maneiras: C(#4) = Dó com Quarda Aumentada (neste caso o # é para caracterizar o intervalo de Quarta Aumentadada) ou C#(4) Dó sustenido com Quarta (O sustenido está na nota Fundamental).

2) Não deixe espaço em branco no meio do nome da cifra: Ex: C7 9. Para separar os intervalos não utilize espaços em branco. Utilize parênteses ( ) , barra / ou ponto . para serara-los. Ex: G7(9) G7(9/13) G7(9.13)

3) Utilize apenas os símbolos abaixo (que representam intervalos) quando for escrever o nome de um acorde:

Intervalo Descrição Simbolo Utilizado Exemplos

----------- ------------------------- -------------------------- -----------------------------------------------------

2m Nôna menor b9 C7(b9)

2M Nôna maior 9 C7(9)

2aum. Nona Aumentada #9 C7(#9)

3m Terça Menor m Cm

3M Terça Maior Não informar C = Dó Maior

4j Quarta Justa 4 ou sus4 ou 11 C4 ou Csus4

4aum Quarta Aumentada #4 ou #11 C(#4) ou C(#11)

5 dim Quinta Diminuta b5 Cm7(b5)

5 aum Quinta Aumentada #5 C(#5)

6m Sexta Menor b6 ou b13 C7(b6), C7(b13)

6M Sexta Maior 6 ou 13 C6 ou C13

7 dim Sétima Diminuta ° ou dim C°

7 Sétima (menor) 7 C7

7M Sétima Maior 7M ou Maj7 C7M ou CMaj7

Qualquer outro símbolo utilizado para montar o nome de um acorde será rejeitado pelo Cifracil. Por exemplo: C- (Dó menor), embora seja muito utilizado também nos métodos de cifragem não será reconhecido pelo Cifracil.

Observação: O Cifracil desenha a digitação dos acordes, e em varias telas mostra as notas e os intervalos dos acordes abaixo da ultima casa da digitação. Resolvemos representar o intervalo de Sétima diminuta com 7d em vez do simbolo bb7, que seria mais correto. No entanto assim o fizemos por uma questão de espaço ocupado pelo símbolo bb7. 7d ocupa menos espaço do que bb7, e como o espaço entre as cordas é pequeno achamos por bem, para que o símbolo bb7 não fosse sobrescrito pelos símbolos das cordas visinhas, utilizarmos 7d, que é mais compacto.

4) A nota do baixo de um acorde deve sempre ser precedida por uma barra /. Ex: C/G

5) Você poderá utilizar o símbolo * no final do nome do acorde com o objetivo de diferenciar digitações diferentes para um mesmo acorde em seu documento no Cifrácil.. Ex: E(Primeira digitação encontrada no seu documento) E* (Segunda digitação) E** (Terceira digitação). Embora estes três acordes sejam Mí Maior, cada um poderá estar sendo tocado com uma digitação diferente em trechos da música cifrada. Ao utilizar esta convenção ( o asterisco ), quando o Cifracil interpreta o texto, estas três digitações, utilizadas como exemplo, aparecerão como se fossem acordes distintos na aba Repositório de Acordes. A partir daí basta que você modifique cada digitação através do botão Modificar Digitação Acorde Selecionado, já que os três acordes em questão aparecerão com a mesma digitação no momento da interpretação. Isto acontece porque o Cifracil pega sempre os acordes com digitação definida como Default.

6) Poderá utilizar cifragem com subscrito e sobrescrito. Basta ir no Menu Principal, e entrar na opção Configurações e em Seguida Página de Impressão.

Se marcar a opção Usuar Subscrito nos Acordes na Pagina de Preview, fará com que o Cifracil na montagem da pagina de preveiw do documento transforme em subscrito acordes do tipo X a/b, onde a é o subrescrito e b o subscrito. Exemplos para estes acordes: A7/4. A regra é muito simples ao utilizar / o cifracil entende que você está querendo fazer sobrescrito com o elemento a esquerda da barra e subscrito com o elemento a direita então no nosso exemplo temos A7/4 transformará em A (fará sobrescrito no 7 e subscrito no 4). Se separar os intervalos utilizando um ponto . o cifracil não fará subscrito Ex: A7.4 (não terá subscrito).

Há alguns cuidados que deverá tomar.

Imagine o acorde A7/4/9 o Cifracil interpretará assim:

A (sobrescrito 7, subscrito 4, sobrescrito 4 e subscrito 9) , gerando uma formatação erronea.

Reescreva este acorde assim: A7(4/9) então o Cifracil fará: A7 (Sobrecrito 4 e subscrito 9) assim está correto, ou escreva A7/4(9) ou A7/4.9 e o Cifracil fará: A Sobrescrito 7 subscrito 4 (9)

Outra coisa a evitar. Quando tiver duas sequencias de subscritos o parenteses deve ser usado da seguinte forma: Ex: A(7/4.9/13) ou A7(4/9.13) ou A7(4.9/13), não utilize A7/4(9/13), pois o cifracil não pegará o parêntese inicial.

Lembre-se as regras da / para subscrito só valerão se a opção Usar Subscrito nos Acordes estiver marcada.


quatro elementos básicos

O editor de textos do Cifracil trabalha com 4 elementos básicos do texto. São eles:

. Título: Título da Música (deve ser colocado sempre na primeira linha do seu documento)

. Autor: Autores da Música (deve ser colocado sempre na segunda linha do seu documento)

. Cifra: Representa o Nome do Acorde. Ex: C7 F G#m7(9). Estará sempre escrito em cima da letra da música. A linha de Cifra deve apresentar apenas os nomes dos acordes. Se você quiser colocar algo que não represente um acorde, como um comentario, utilize-o entre colchetes. Ex: [Introdução da Música] C F G

. Corpo Texto: É a letra da música: Ex: "Olha que coisa mais linda ..."

Cada um destes elementos possui propriedades que podem ser configuradas na palheta de estilos do Cifracil. São elas:

Fonte do Texto: Ex: Times New Roman, Courier New, etc

Tamanho do Fonte: Ex: 10, 12, etc

Negrito, Itálico, Sublinhado, Cor

Alinhamento (Só utilizado nos elementos Título e Autor)


Preview Documento

Como você pode ver na figura acima, o preview do documento, é a pagina de impressão que o Cifracil monta, juntando o Texto Cifrado e o desenho dos acordes, as digitações utilizadas no documento. Vamos examinar a barra de ferramentas desta tela de preview:

A Escala permite voce visualizar o documento em tamanhos diferenciados, permitindo a voce aumentar ou diminuir na tela a visualizaçao da sua pagina mostrada no preview.

Exemplo. Se voce clicar na setinha da caixa Escala e escolher 50%, ira ver a pagina de impressao no preview diminuida pela metade do seu tamanho.Assim podera ver, por exemplo, como esta o visual da pagina toda de uma so vez.

Os bitoes com desenho de lupas mostradas acima com sinal de + e - servem para controlar a escala de visualização do documento. O + indica que voce esta aumentando a escala e o - indica que voce esta diminuindo a escala. Pressione a tecla Control e a tecla + e voce estara aumentando o documento progressivamente, como se estivesse clicando na lupa com o desenho do +.

Também podera utilizar as teclas de atalho Contro e - para ir diminuindo a escala do documento.

Utilize as setinhas para cima e para baixo para ir mudando a pagina do seu documento no preview. Também poderá utilizar as teclas Page Up e Page Down para avancar ou retroceder as paginas do seu documento. Se você quiser ir diretamente para uma determinada pagina então clique Control + Tecla G e abrirá uma janelinha pra voce pedindo o numero da pagina para onde deseja ir. Basta informar o numero da pagina e voce pula diretamente para la.

Estes botões servirão para navegar entre as páginas do preview.

Na ordem dos botões de esquerda para a direita:

Botões:

1) Vai para a primeira página, Tecla de Atalho:Tecla com Seta para Cima

2) Vai para a pagina anterior, Tecla de Atalho:Tecla com Seta para Esquerda

3) Vai para proxima pagina,Tecla de Atalho:Tecla com Seta para Direita

4) Vai para última página,Tecla de Atalho:Tecla com Seta para baixo

Vamos explicar agora os seis botoes acima, numerados da esquerda para direita:

1) Abri uma tela onde voce podera mudar a orientacao do Papel entre Portrait (Retrato) e Landscap (Paisagem). Tambem podera escolher o Formato do Papel a utilzar : Ex: A4, Carta, etc.

2) Chama o dialogo de impressao, onde voce podera escolher a impressora a ser impressa, escolher o intervalo de paginas a imprimir e o número de copias a serem impressas do documento. Há um detalhe interessante aqui. Antes de voce clicar neste botão, voce podera escolher se quer imprimir apenas as paginas pares ou impares. Basta marcar nas caixinhas [image] uma das duas opcoes. Se não marcar nenhuma das duas o programa assume que voce não quer excluir da impressão nem as paginas pares e nem as impares.

3) Serve para voce abrir um preview que voce salvou no formato .prv dentro da sua janela de preview. Ele perguntara se voce deseja limpar o preview corrente, responda sim e exibira o documento preview que voce salvou.

4) Salva o seu preview no formato Preview (.prv). Voce pode salvar uma musica ou ate um songbook neste formato e podera abri-lo no botao 3. Esta opção é bastante útil, pois voce podera salvar uma musica ou um songbook criado por voce para mandar para algum amigo. E este poderá abri-lo no cifracil. Também deixaremos na nossa hompage para download um programinha que é o Cifracil Reader. Com ele voce podera abrir documentos que voce salvou neste formato. Assim, se voce mandar um documento .prv para um amigo que nao tem o cifracil, basta ele baixar o Cifracil Reader, gratuitamente em nossa homepage e abrir o documento que voce salvou, podendo navegar nele e imprimi-lo.As versões anteriores do cifracil salvavam o priview no formato songbook (.snb)

5) Acessa o help desta tela

6) Este botão permite voce exportar o seu preview para os formatos Jpeg, Bitmap e Metafile. Os arquivos que serão gerados terão o nome que voce escolheu+uma variação no nome de 1,2,3 etc que equivale ao numero da pagina do seu preview. Ou seja, o preview quando é exportado, gerará um arquivo para cada pagina do seu preview. Se voce tiver com um documento de 10 paginas abertos no seu preview, serão gerados 10 arquivos no formato que voce escolheu.